UI Frozen after sleep

I’ve had this issue with Cubase 8 and 9, and I’m not sure what’s causing it, especially since this was happening with a brand new installation of Windows 10.

Replication steps:

Open Cubase 9
Open Cubase 8.5
In Cubase 9 create Blank new Project in a folder on E drive (4TB HGST 7200RPM)
Leave session open.
Return the next day. FYI my monitors are one and it appears my PC never went to sleep.
Cubase UI is frozen and will not respond. “Show Desktop” or other Windows commands are unable to move the Project window. Cubase 8 and 9 are both using 9% CPU in the Task Manager and are “Not Responding”.

Any ideas? Thanks

There is never any record of this in the reliability history. When this happens I can see “Not responding” on the details of the Cubase9.exe. Is there any way I can recover a dump file from this?

I’m afraid this is no surprise. There is a reason why most DAW configuration articles recommend to run in High Performance mode, which disables sleep.

During sleep, several sub-systems are shut down, power is interrupted for most devices and drivers are likely to be disconnected, which is why many peripherals need to be unplugged and plugged back in after sleep - this is not a problem with a direct input joystick, but it likely will with audio cards and external HDs used for data.

I don’t know why it looks ‘on’ when you get back to it the next day, possibly the system just ‘wakes up’ due to the hang.

In short, Cubase should not be running during sleep mode, when and if you need to keep the system on overnight.

I disabled sleep to see if that affects anything. Same problem this morning. I had started a session loading last night and this morning it is frozen. The message “XXX track is missing” came up like normal for this particular session, but after closing that dialog and the session opened, the UI was frozen and cubase was not responding.

Interesting…I thought I had disabled sleep through the windows 10 UI, but when I went to Steinberg Power scheme, I discovered it was still set to sleep after 30 minutes. In the screenshot you’ll see windows 10 sleep set to “Never” but the old Windows 7 Control Panel window still says sleep after 30 minutes.
power settings.PNG

Hi Fabio,

Windows (and Mac OS X) provide all the necessery application programming interfaces (APIs) to handle the required power management scenarios.

It is CUBASE that is poorly coded in this respect and, more specifically, the problem appears to relate to the eLicenser. It appears that CUBASE locks as if the USB is removed (when the computers goes to sleep mode).

On a desktop computer, one might select the power hungry “Always On” mode, but on a laptop, which is typically used by mobile users on a train or an airplane, Cubase should allow for making best use of the laptop’s battery.

Please raise a flag with Steingerg’s software engineering team and let them know that there are customers who need Cubase to run on laptops that do go into sleep mode, to save on battery life, and these customers are not happy with Cubase locking down like this.