UI glitch

Hi everyone,

workarounds in a laptop with Intel and NVIDIA graphics adapters:

  1. Run NVIDIA Control Panel [*] click on ‘Manage 3D Settings’, then click on ‘Global Settings’ tab and then click on the pop-up menu ‘Preferred Graphics Processor’, there are three options: Auto-select, High performance NVIDIA processor (HPNP) and Integrated graphics. Choose HPNP and click ‘Apply’ button. Alternately, in ‘Manage 3D Settings’ the ‘Program Settings’ tab lets you choose a graphics proccesor for every program, select HPNP for Halion 6

  2. In Windows 10 [*] right click on the Halion 6 desktop icon, click on ‘Run with graphic processor’ and then click on HPNP

In other words, Halion 6 only works fine in my laptop using HPNP it doesn’t have to do with standalone or DAW mode. No issue in Halion 5 in the same laptop and OS using every graphic processor so Steinberg should take a look at this issue

I hope that helps

Regards

[*] Windows 10 and NVIDIA Control Panel are installed in my native language so options name could be different in English. Furthermore, NVDIA Control Panel could be different in you computer

Hello Steinberg,

any chance that this issue (no text with Intel onboard grafics) will be fixed by Steinberg ?
Or must I buy a graficcard for my music-PC (what I dont’t want to do).

Tyaetsch

Hi,

if you graphic card is not supported by your operating system, there is nothing we can do on our side.

EDIT: Forget what I have said! There will be solution coming with the HALion 6.0.10 maintenance update. Sorry for the confusion.

I have the same UI glitch under WIN10, but it is definitely NOT due to graphic card incompatibility.

Please test the following: under Cubase, start an instance of NI Kontakt, close it and start HALion. Then the glitches are gone! Obviously Kontakt intializes something related to the graphics interface, that HALion doesn’t. There must be faulty technical changes in H6 related to graphics, because H5 doesn’t have these glitches under the same WIN10 system.

I hope Steinberg hears me and can reproduce the described workaround to find the bug.

We hear you and we are trying to reproduce your workaround. There will be solution in the HALion 6.0.10 maintenance update.

Will it also fix the Bitwig 2 UI glitches?

When can we expect this 6.0.10 mainenance update to be released?

Best,
Harald

I have an Intel HD 2000 graphics adapter, which is stated not to be compatible with windows 10.
But:

  • I did not encounter any graphics problems until Halion 6
  • In Halion 6 standalone the tabs don’t show properly, in halion sonic 3 standalone they DO though
  • As a plugin in Cubase 9 Halion 6 does not show the tabs properly, halion sonic does.
  • When I load an older project with a Halion track, the tabs display correct, and from that moment when creating a new project with Halion 6, the tabs display correctly. Until I close Cubase and start a new session: then the tabs don;t show correct.
    So this seems not to be a display adapter problem.

Reinstalling Halion, choosing another screenset, or replacing the editor folder -as mentioned above- do not solve the problem for me. Until now, I did not get Halion 6 standalone get to work. :frowning:

Same here. I CANNOT believe Steinberg didn’t still find a fix for it.
Fuz!

Here is a piece of good news! The solution announced by Matthias worked for me on Intel HD 2000 GPU.

https://helpcenter.steinberg.de/hc/en-us/articles/115000934990-User-Interface-errors-in-HALion-6-on-Windows

Best regards

Miloslav

Yes I was so happy to purchase and download Halion 6, to my dissapointment, there are two issues, sidechaining of the VST should be universal in any DAW but the main point in Standalone I have this exact same glitch, and also the Macro Page designer does not load, I am using Windows 10, also what is so funny about this, if you open the VST in say FL Studio, or another DAW, the interface looks normal, so that sort of tells me this has something more to do with the coding than Windows 10, am I right or wrong about this, and it does need to be addressed if people are paying for this software and the previous versions were working fine… I also tried that registry fix, no dice…

This has been fixed already. update your Halion.

Great, but it doesn’t fix Halion Sonic SE3 - which has the same issue (still, in Cubase 9.5.10).

The same problem is back again with Halion 6.1 update.
Applying the registry fix again doesn’t seem to work.

UI glitch in 6.1 update come back, d2dfix.reg d’ont resolve, the issues persist.

ErroHalion61.png

yes me too ,been having problems with wavelab 9.5 elements and Cubase pro 9.5 ,halion 6 .1 all the tabs are funny and halion sonic in the options screen .Cubase pro 9.5 clicks back ok when i open the score edit .

i can confirm that when i open an instance of ni kontakt the glitch has gone .

Yep, the UI glitch is back again with the 6.1 update.
The d2dfix.reg file which fixed the UI glitch in the 6.0 version doesn’t fix it anymore.
Could it be that some registerfiles where renamed with the update so that the register path in the d2dfix.reg file isn’t correct anymore?

Steinberg since you fixed the problem in a previous version it shouldn’t be so hard to fix it in the new update 6.1 version.
Please help.

Best Harald

Same UI glitch with Intel HD Graphics 4000