Unable to create new instruments

In my first attempt to create a new instrument, I’ve found myself unable to create a new instrument that Dorico will display. Creating a variant works as expected, but creating a new instrument does not work.

I’m attaching a project file which started from the Solo Piano template and I tried to create a new instrument based on the piano. When I try to change the existing instrument to “Piano copy2”, Dorico does not display staves for the instrument. Same result if I add a new player and select the new instrument.

I can get the results I need by using other existing instruments, but I also want to know why I’m not able to duplicate the instructions from the video here.

I’m on Dorico 5.1.40 and MacOS 14.5

Instrument Editor issue.dorico (517.8 KB)

I’m sorry to say that this is a bug: Dorico is unable to find the right name for the instrument, and it’s therefore failing to create it. We have a fix for this in our development builds and we’ll get a fix out for it in the near future.

4 Likes