Unable to create slash voice in drum kit

I have a project where the procedure John describes at 6:08 does not work.https://www.youtube.com/watch?v=yTsaKi3i80Y&fbclid=IwAR0aXd4moI7OQP1xFf2XqxdmeA-ccVGpzziWjI1YSWKmaEKtH018Iq96O3s I can open a new big band score, and it works fine, so this misbehavior must be a side effect of something else I have set in my project.

I create the slash instrument in setup mode. I switch to write mode and start note input in the drum kit part. Screen looks just like John’s, and my test score. It is showing Sl. for note input on the middle line of the 5 line staff as it should. I enter Y, and instead of a slash I get a standard notehead. Plays back as wood block, just as John’s did.

I’ve checked engrave->notehead sets->slashes. No difference between test and actual project. engrave->engraving options->rhythmic slashes is set to oversized.

What else should I check?

Are there other instruments assigned to the same middle staff line in the Edit Percussion Kit dialog? If so, when you get the caret to the relevant staff line, if you type Alt+Up (multiple times if necessary) Dorico will loop round the available instruments/playing techniques/noteheads for that staff line.

No other instruments are assigned to the middle staff line. Just slash.

Zip up and post the project (or even a cut down version of the project) and somebody will take a look.

Mystery solved. Slash voices currently do not play nice with the Notation Options -> Percussion -> use single voice. Hopefully will be resolved in the future, but the workaround is to right-click on the notes that are supposed to be slashes and then use the Notehead > Slashes option to manually change them. Thanks John Barron for debugging this for me.