Unable to download Dorico 4 upgrade

Hello,

I’ve been completely unable to get Dorico 4 (upgrade from 3.5) to download through the download assistant. Based on this thread: dorico-3-5-upgrade-to-4-bad-bad-time/760501
I attempted a direct download of Dorico 4 Installer, Dorico 4 contents, and Halion 3.5 (Halion lead to a bad page).

I asked for help with the license on the Dorico Facebook page and got no response, so I deleted that post after a couple of days and opened a Support ticket (ref:_00D30F1z._5004S3LICL:ref) and they completely dropped me.

This is my first bad experience with Dorico and I’ve been working on this for over 2 weeks. Steinberg download assistant looks like this:

Steinberg Activation Manager says my Dorico 4 is activated.

As far as I can tell, I don’t have any functional part of the application to be able to boot. I just get sent to the Activation Manager when I try to boot Dorico.

Thanks in advance,
Mac OS 12.4
Studio Mac w/Silicone chip

My guess is that this is some sort of problem with the Steinberg Download Assistant. In order to get you going it might be easiest to download the different installers directly rather than using SDA to download them. You can do that here: Dorico 4 Updates and Downloads | Steinberg If you already have Dorico 3.5 you will just need the Dorico 4 application installer and the HALion Sonic SE 3.5 installer - you don’t need to re-download the content.

Thanks for your response -
That’s exactly what I tried doing after reading the Forum post I referred to. The Dorico 4 application installer seems to have run, but it keeps sending me to the Activation Assistant, which tells me I’ve already activated it, but the program does not boot.

HALion Sonic link was broken and I was not able to download it.

Good to know that I don’t need the (already downloaded) content .iso file.

What is a good next step for me?

First, could you ensure you are running the most recent version of the Steinberg Activation Manager (currently 1.3.1). Second, could you run the Steinberg Activation Manager on its own (without running Dorico), take a screenshot of what it shows and post it here? Third, could you zip up the following directories and either post them here or email them to me (r dot lanyon at steinberg dot de):

  • /Users/yourusername/Library/Application Support/Steinberg/Dorico 4
  • /Users/yourusername/Library/Application Support/Steinberg/Activation Manager

Regarding Richard’s advice to make sure you’re running the latest SAM, if you’re having problems with SDA, you may not be able to have SAM automatically updated by SDA. You can download SAM itself from here:

The Activation Manager looks current.

Here are those other files:
Activation Manager.zip (51.0 KB)
Dorico 4.zip (2.4 MB)

Richard is more skilled at reading the runes of these logs than I am, but it certainly appears that Dorico is activated, but that Dorico itself is unable to connect to the license engine to obtain a license.

I’m sure you must have tried this, but since I think Richard is probably very wisely now asleep, perhaps just give it a go, and he will come back to you in the morning in any case.

Quit Dorico and quit SAM, and wait thirty seconds. Then look in Activity Monitor: do you see a “Steinberg License Engine” process in there hanging around? (You shouldn’t: it should exit automatically when the last client app using Steinberg Licensing quits, after waiting 20 seconds to make sure it’s not going to be immediately needed again.) If you see the process there, please try force quitting it.

Then try running Dorico again: does it now run up correctly?

That just takes me to the Activation Manager for the same loop I’ve been stuck in. I appreciate that you guys are in the Euro time zone, and I need to close out for the evening as well. I will check in tomorrow and see if Richard has discovered something.

Thank in advance, I’m looking forward to the new version.

George

Hi George,
This is quite odd. As you say, it looks as though SAM can run perfectly well on its own, but for some reason Dorico can’t talk to it. One possibility is that something has got messed up during an update and you’ve been left with some vestiges of a previous version of SAM. I’ve PM’ed you a script that will completely delete all the existing SAM binaries so that you can try reinstalling from a clean slate.
Richard