Unable to Get Past eLicenser

My computer spent many hours updating today.
When I tried to run Cubase AI 8 after I got a license issue (it worked perfectly fine just before).

What happens:
Cubase AI 8 complains about a license and I allow it to pop up a box for me to enter a license.
I have the latest eLicenser Control Center and the code I need it on my products page so I paste it in.
It recognizes the code and shows Cubase AI 8.
It tells me to select an eLicense to download.
I click “Download License”.

I am told that the code is already used once and I should contact my vendor for another.
In my “My Products/Software” page, if I click “Request support” it takes me to a Japanese forum, and my Japanese is too rusty to wade through it.

I am completely stuck. Maintenance does nothing, I have the latest eLicenser Control Center, it just refuses to download or use the license because of my Windows updates.
What can I do?

L. Spiro


Could you attach a screenshot of the message, please?

I guess this could fix it (if you are on Windows, and it’s the common Windows issue):

  • Right-click to the eLCC application.
  • Start it as Administrator.
  • Start Maintenance in the eLCC application.
  • Quit eLCC.
  • Start Cubase.

Maybe the most important step was to quit eLicenser Control Center!
It works now.

L. Spiro