Unable to hear playback in Dorico 5 (case 2)

2 posts were split to a new topic: No sound on playback, but exported audio sounds OK

I had a look through Eric’s log files and stuff, but could not find anything… Don’t know how to proceed on this one…

Thank you for your efforts, Ulf.
Could you tell me what are the next steps, if any ?

I also have the same issue as Eric on two separate Windows machines connecting to 3 different external MIDI devices (Disklavier C3X, Motif XF6, Kronos) that all work fine in 4.3. Instruments etc. and other settings all look the same, and clicking on notes gives note on, but no note off.

1 Like

Hi @Eric2000 and @inyouendo , this is going to become a difficult one, so please bear with us. Sooner or later we will find out what is going on.
First we need to find out, where the MIDI data gets transformed into rubbish, either on Dorico end or audio engine.
@Eric2000 , from your logs I can see that you still have HALion Sonic SE and all the sounds installed. If you add one HALion instance in Play mode and route one of the players, that normally send to external MIDI, to that HALion instance instead, does HALion then also not play or how is that behaving?
I:m also considering creating a special version of the VSTAudioEngine with some instrumentation and extra debug output, but that will take some time.

At both of you, do you still have a Dorico 4 installation that you can work with in the meantime?

Hi Ulf,
Great to hear that I am not alone anymore… :wink:
Also happy that the Dorico’s team is ready to investigate further on this issue.
I will try your idea today and I will keep you posted.
Fortunately, D4.3 is still working fine and I can continue to work as usual.
As former software programmer (on macro assembler with Z80 CPU and CP/M 16K, in a previous life !! :grinning:), I fully understand that such debugging takes time.
If I can help by testing some of your possible solutions, do not hesitate to contact me.
I mostly appreciated your (Daniel, Richard and you) reactivity and kind assistance on this topic.


Hi Ulf,

So, I did what you proposed, i.e. I took the bassoons track which I routed to a VST Halion instance. Then I selected the bassoon instrument in HalionSonic7 window.
When I tried to playback the whole project, I could hear only the Halion bassoon, all the other tracks remaining silent.
The “rubbish” MIDI data are still sent to the other MIDI instruments.
I hope that I answer your question.

Thank you very much @Eric2000.
That information is indeed useful as it suggests that the audio engine is doing wrong with the MIDI-data. Now, I also need to consult other engineers .,but since we entered a long weekend, I can only do from Tuesday onward, so a little patience please. Thank you

1 Like

Hi Ulf,

I currently use Cubase 12 Pro, but have been evaluating Dorico SE & Pro to see how it can fit into my workflow.

Both my setups below exhibit the same issues for external MIDI devices:

Win 10 Laptop: core app minimal install for Dorico 4.3 & 5 (min install for Cubase 12 also, so no VSTs). I’m using Dorico 4.3 Pro (trial) and Dorico 5 SE hooked up to my Disklavier C3X via Yamaha USB Midi. I have a Focusrite Clarett+2Pre via USB and is the ASIO driver selected.

Win 10 Desktop box: Dorico 4.3 Pro (trial) with full install . Dorico 5 SE full install (also Cubase 12 Pro full install). Hooked up to Yamaha Motif XF6 via Steinberg FW driver. Korg Kronos hooked up via USB midi device. Steinberg FW ASIO selected.

Hi @inyouendo , thank you for the information.
Interesting point is that you are on Windows while Eric is on Mac. For us engineers that is an important information.
As I wrote before, we are going to work on this, but can’t make any promise when we have a fix for it.

I am on Windows 11…

Hi Eric,

Glad to add my voice! I wasn’t sure if it was me doing something wrong, so waited to see if someone else had the problem first :slight_smile:

Oh, and my software engineering life started out programming Z80 at the age of 11, so it looks like we have more than the same Dorico issue in common!

Hi @Eric2000 , oh sorry, I’ve mixed that up. There is currently so much traffic here and I have to go through so many diagnostics reports that my head starts spinning like a Mac beachball as well :wink:
Right, you are also on Windows, sorry again.

1 Like

No problem. :slightly_smiling_face:
I mentionned it to avoid any confusion in your future investigation.
Would you like to have the detailed specifications of my desktop ?

Yes, would be good. You can open a Command window and then run dxdiag and post the output here. Thanks a lot

Here you are :slightly_smiling_face:
DxDiag.zip (21.9 KB)

1 Like

Similar to the situation described in this post. Dorico 5 doesn’t play back anything at all for me: neither brand new nor older projects.

I am able to audition and play instruments. I can record MIDI in real-time using the keyboard and TEC breath controller. Dorico 5 records all the notes and all the used CC controllers.

However, Dorico appears to not be sending any MIDI out on playback, except for reset messages. Mouse-clicking on an existing note causes some kind of glitch in the instrument (audio loop), which I can stop by clicking “P” (resulting in playhead moving in silence) or panic reset in the VST itself.

I am not using any VSTs in Dorico except for the metronome, the MIDI goes out to Cubase via loopMIDI.

So: while testing D5 for latency compensation, I was able to record this bit, but it won’t play back.

Opening this project file in Dorico 4 plays back perfectly, although it did display this strange warning:

Here’s the file:
Dorico_MIDI Out Issue.zip (945.5 KB)

I tried making a new project file and recording a single instrument in real time. I tried entering notes manually via the keyboard rather than playing them in, but the result is the same: Dorico doesn’t send MIDI out.

1 Like

Daniel has explained that this is because they changed something in D5 file format relative to D4. You can safely ignore this.

1 Like

Hi @ebrooks , I really think this is the same issue as described in the other posting that you already mentioned.
Even though Dorico and the audio engine have a logging system, there is not much logging in there for the MIDI streams, so I will make a special version where the audio engine writes out the MIDI messages it receives and transmits and then hand out that version to affected users. By means of that we should be able to find out quickly where the problem is, at least that is what I’m hoping for. Just give me some time to create such special version.


Thanks @Ulf, no worries. I went back to D4 for the time being. Many thanks!

EDIT: Just to mention one other thing - watching the controller values in the VST instruments, it seems to me that it’s not only the Note-On and Note-Off messages that Dorico has trouble sending out. I have recorded the controller tracks too but they all appear dead in the instrument. loopMIDI also shows zero MIDI information being sent. You probably already know this but just in case.