Unable to Insert Bars at Start of Selection or End of Flow

I’ve never had an issue when attempting to insert bars, or delete bars from part of my project. Now, after realizing that I need insert 4 bars in the middle of my project I’m unable to do so.

In Write mode, I do the following:

  • Select a bar line

  • Click on the Bars and Barlines palette

  • Under Insert Bars, I choose Start of Selection, and provide a value of 4 [bars].

  • Click on the Insert Bars button

Nothing happens. I repeated this process in another project and no problem. The bars are inserted flawlessly.

I’ve even tried to go to the end of the project and just insert bars - click on a bar line, type Shift+b and type the number of bars that I want to add. Nothing works [in this particular song]. No problem with any other song.

I’m at a loss as to how to fix this. Any thoughts would be most appreciated.

Thank you,
Tony Ventura

My guess is that this flow has malformed bars/time signatures, possibly the result of a dodgy MusicXML import. It’s nigh on impossible to tell you what to do to fix it, without seeing the project itself. If privacy is an issue, you could filter and delete all the notes before zipping and uploading.

I think you’re on to something, because I did do a MusicXML import and had to fix a few bars that did not abide by 4/4 time. Maybe starting with a fresh score and copy/pasting the music from the existing score.
Thank you, pianoleo, for your thoughts,

Select All and Copy and Paste into a new flow (a new flow within the same project will do fine). Do Select All using the keyboard shortcut or by using Edit > Select All. Do not use the System Track for this. The System Track will select everything, including barlines, and you need to select everything apart from barlines. You may need to add in time signatures after pasting.

Looking and the properties of the barline(s) around where you have the problem might be enough to find it without copying and pasting everything. Display all the signposts, as well.

Time signatures are effectively properties of bar lines, not independent objects.

Thank you Rob, I’ll give your suggestion a try. I’m appreciate your comments!

I have found that, let’s say in bar 5, if I click on the barline, I can easily type Shift+B, type 10, and 10 bars will be inserted. However, if I click on the ending barline for bar 6, repeating the process of trying to add 10 bars nothing happens. I’ve examined the properties of every note and barline in both measures 5 and 6, as well as showing all signposts (I actually don’t have any signposts), and I don’t see anything different (property-wise) between measures 5 and 6.

I have a feeling that the fix is very easy. I just haven’t found it yet.

Tony, if you could post (an excerpt of) the project that reproduces the problem, we might be able to find out what is going wrong.

Thank you, StefanF. I have reduced my score considerably but unable to attach the file because of the file extension, “.dorico”. Can you please tell me the preferred method posting an except.

Zip it, then attach the resulting zip file.


Please find the attached file.

After opening the file, click on the barline for bar 5, type Shift+B, type 3 or whatever number you want. You’ll that 3 bars were inserted after bar 5. Now, undo the addition of “3” bars. Repeat the same steps only this time click on the barline for bar 6.You should experience that nothing happens, no bars are inserted.

Thank you for any assistance.
Tony Ventura
SOMETHING JUST LIKE THIS_for StefanF.dorico.zip (952 KB)

There does indeed appear to be a problem with the code that works out the prevailing time signature at a given position in this particular instance. You can work around this for now if you temporarily delete the Segno marker in bar 5. Alternatively enter “+12q” into the popover, as that will just enter 12 crotchets/quarter notes, regardless of the time signature. We’ll fix this problem in an upcoming update.

Thank you StefanF -

If I use the Bars and Barline (Shift + B) popover it just adds 12 quarter notes to the “existing” bar. I don’t see how this adds bars, which is what i need to accomplish. I’m probably missing something very basic.

Thank you for any additional clarification.

After some experimenting, I found the culprit. To see it, open Engraving Options > Time Signatures > Design > Open meter appearance, and select the second option (X).
Now select any barline after bar 5, and untick ‘Hide time signature’ in the properties panel. You’ll see an X appear. You’ll find that every single bar after bar 5 has this explicit open meter, albeit for 4 beats all the time. Dorico is unable to add bars if their length is officially undefined.
This error is probably caused by importing clumsy XML.

To repair this: select all barlines, untick ‘Hide time signature’, then delete all the X’s.

Edit: Reading Stefan’s response in the meantime: do you mean that inserting the Segno (in Dorico) caused this?

Edit #2: It’s confusing (see above) when open meter is totally invisible, because of Engraving Options. It would be better if there was a signpost showing for it anyway, even if the TS is not hidden per se, but just not represented by a symbol.

Thanks Peter, the Segno is indeed unrelated. The open time signature(s) from bar 6 are the problem here, and they are also the reason why adding just 12 quarter notes doesn’t add more barlines in that new range.

Thank you so much PjotrB. I would have never found this is a million years.
Have a great day!