Unable to install Cubase Pro 8

I’ve decided to f*** C11 off and revert back to C8 Pro. I’ve lost Halion 5 completely plus Sonic so no instruments there at all now. Dorico 3.5 won’t even install and I can’t find Olympus Choirs anywhere.

I can’t reinstall C8 because the license is now for C11.

This has been the most ridiculous and frustrating exercise in futility imaginable. If I wanted this kind of s*** in my spare time I’d go to work.

If this is progress then take me back to the stone age.

I have put a request for help into our friends at Steinberg but I’m not hopeful.

Why going backwards when cubase 11 is doing so well?

No, the problem is elsewhere… the license and the installation are completely independent.


Could you be more specific, what exactly doesn’t work on the installation process, please?

Installation is not affected by license at all. With Cubase 11 Pro license, you can start Cubase 8 Pro.

Are you on Mac or Windows? Are you sure you’re system is not infected by any virus?

Why/how did you lose HALion 5?

I get a message popping up declaring some installfiles.cab are missing or corrupt. It will continue to load content but not the actual application.

Thus: I formatted a spare SSD and I went back to W7 and tried to reload C8. Same thing. It loaded all the content but the application failed.

Likewise Absolute2: whereas that once worked fine in W7 now it too won’t load from USB. I have to do each set ‘manually’ which takes ages.

I think it’s time to admit defeat and abandon it altogether.

Perhaps, so why is the license for C8 no longer present on my e-licenser (dongle)?

Because ever since I rashly took the decision to upgrade, I haven’t been able to work on a single piece of music so the question becomes: why bother with it anymore?


Could you provide the exact message, please?

What do you mean by this? What is “on the USB”, please?

Because you updated your Cubase 8 license to Cubase 11 license. Your Cubase 8 license was replaced by the newer one: Cubase 11.

Thanks Martin. I suspected that was the case but I would argue the newer license should still allow it’s predecessor to work as it did before.

I’ve managed to retrieve Halion 5 and Sonic by manually reinstalling from my Absolute2 dongle. However, Symphonic Orchestra will not work and all I get is a large red ‘License Missing!’ on a blurred background. This is a tad inconvenient as most of my work is orchestral and even other compositions invariably include stringed instruments.

I did consider upgrading Absolute to A5 but it would appear it’s only possible from A4 to A5.

But: I am resolving most of the issues…


I’m sorry, I’m afraid, there still not enough information to be able to help.

What do you mean by this? On the USB-eLicenser, there is no installer. You cannot instal from the USB-eLicenser. Or do you have a backup of Absolute 2 installer at any USB pen/drive?

What do you see in the eLCC, please?

No. AS you can see on the attached screenshot, there are updates from every Absolute version available. I selected Absolute 2 for you, on the screenshot.

Sorry Martin, I meant the USB Absolute 2 dongle not the elicenser dongle.

The ELicenser is valid for Absolute2 so all those instruments should be available but maybe I downloaded a later version: I’ll uninstall then reinstall from the A2 dongle and see if that works.

Thanks for that: when I checked out the Steinberg site all I could find was the update from A4. That would certainly solve the missing orchestral samples as they are included in it. Mind you, it’s not exactly inexpensive is it?