Unable to login for first time - Login times out

Hello all. I am running Cubase 10.0.40 (latest version) on Windows 10. I have updated all my elicensers and MySteinberg account information. I can login in to vst Connect. However, when I try to login to VST Transit, I enter my email and password correctly but the “Log In” Button simply spins for a second and then nothing happens. Please help!

are you sure you’re not just logged in - “nothing happens” seems to indicate that. Can you see your profile, friends etc?

No, definitely not. It stays at the login screen window and just sorta times out.

Does that mean it’s frozen, or can you access your profile page or anything else (right click top right)?
Also, are you possibly logged in with VST Connect (not Transit, but Connect)? That won’t work.
Not aware of any such occurence otherwise. We need more information. Look at the bottom line of the plugin, does it reveal any information? And we really need to know what you can and cannot do in this situation.

Same problem here on MacOs. MySteinberg Id works (verified on Transit iOS App), but in Cubase 8.5 I can’t get past the login window. Same procedure as vinja. I updated my eLicenser, registered it again so that the website says it contains a license for VST Transit, but nothin happens when I try to login besides the short cursor spin. No log, no error … :confused:
The status bar on the bottom of the VST Transit window displays nothing but an (X) to the right, as if it is trying to connect and I could abort that. (just like in web browsers).

Ty for replying musi. The login screen is indeed frozen. I am unable to proceed to the projects window. Just as shaitan mentioned, a quick spin of the cursor when clicking “Log In” button and then nothing.

I mentioned the fact that I can connect to VST Connect just to clarify that Cubase is communicating with the server… this issue is completely with VST Transit. If helpful, I’ve never connected to VST Transit before. Im a first time user attempting to collaborate with a MacOS user on Cubase 10 who is apparently having the same exact login issue.

I’m having the same issue in Cubase 10. On the VST Transfer log in page I’ve entered my MySteinberg credentials but when I click ‘Log In’ nothing happens. Please help us, Cubase Overlords!

We’re looking into this right now, sorry for the inconvenience.

Check your version, actual version is 1.5; this should be installed automatically, but there is a problem with the update server. Unfortunately, it can not be downloaded from the website. Older versions fail to log in just as you describe. We’re on the case and report asap, again sorry for that.

So, it should work again now. Open Vst Transit and it should update, does it work for you?
One more time, sorry for the inconvenience!

Many thanks, musicullum! Vst Transit updated itself and is now working, I‘m logged in! \m/

Thanks for your help, musicullum!

Micha did it all, kudos to him :slight_smile:

All sorted thank you thank you!! :smiley:

I have this problem. I haven’t tried VSTTransit before. I can login to MySteinberg no problem. But with VSTTransit I just get “Start Login…” in the bottom field. I am running v1.5.22.56 through Cubase 10 Pro on Win10 Version 1909 (Build 18363.720). I have no special characters in my password, just numbers and upper/lower case letter.

… is your Cubase version registered at your MySteinberg account?

Yes is it. “Activation status:Product activated on 20/05/2019”

It also lists “Cubase AI 6” and “Cubase 5 Trial”. Both: “Activation status:Not yet activated” Could they be having any effect? Not sure I even know how to remove them…

… can you please contact me? m.spork (at) steinberg.de


we’ve found the bug and fixed it. Please start VST Transit, the auto updater will install 1.5.24 and this one will fix your problem.


Hi Michael,

You’re right, it works now. Thanks for your help.