Unable to login in Download Assistant

Hi all,

I restarted a Windows 10 computer at my parent’s house today, which was not active since August, and the Download Assistant updated itself.
When it finished, it started a window with a single “login” button, which opened the browser and made me login on the website. After that, the browser calls back the application, which does nothing except show the same button again.
I tried uninstalling and reinstalling the application, nothing changed. Suggestions?

Welcome to the forum, sivieri85. Steinberg Download Assistant has just been updated to be linked to your MySteinberg account. If you sign in with your MySteinberg account, you should then find that it shows the expected options for downloading and installing products.

I have the same problem, and I’m supplying the same correct credentials that work to sign into the browser, only after I let it launch the downloader’s link, the download application pops up with the same useless “Sign In” button. This isn’t helpful. I’ve uninstalled the reinstalled the download assistant multiple times, tried multiple browsers, cleared the caches on all of them, etc. Nothing I do lets me log in with my known good credentials. Help?!

…the same in my place… I’m very very annoyed. did the same… installed all fresh - restarted in between… still the same “Sign In” again and again. I need help.

same here!

Thanks for the feedback. I’ll alert the SDA development team to these reports.

You’re welcome. For what it’s worth, I’m a software developer familiar with using the same OAuth protocol they’re clearly using for authentication, and I’ll be happy to help with debugging if they wish. Hit me up with a private message if you want my email or phone. I want to get this issue sorted.

[DELETED]

Our SDA developers have asked for some additional information from those of you who are encountering problems with the new version. Could you please tell us:

• The precise operating system version you’re running (on Windows, run “winver”)
• The browser you’re using (again the exact version number would be helpful)

Please also download the attached zip file that contains a file called application.properties and put it in a folder called steinberg-download-assistant (which you will probably need to create) in:

C:\Users**your-username\AppData\Roaming**

then run SDA again. This will create logs in C:\Users**your-username\AppData\Roaming\Steinberg Download Assistant\logs**, which you should then zip up and attach here.

Finally, please save the zip file that contains a file called Collect_eLicenser_File_Permissions.bat to your computer’s desktop, and run it from there. A file will be created on your desktop after running the .bat file: please attach that as well.
application.properties.zip (773 Bytes)
Collect_eLicenser_File_Permissions.bat.zip (1.45 KB)

unfortunately SDA doesn´t write a logs folder here. I´ve tried C:\Users\your-username\AppData\Roaming\steinberg-download-assistant for the application properties location and C:\Users\your-username\AppData\Roaming\Steinberg Download Assistant. I included the File permissions file from my machine.

System: Win 10 Home 2004 Build 19041.610
Browser: Edge Version 86.0.622.61 (Offizielles Build) (64-Bit)

Also tested it with IE, Opera and Chrome browsers
eLicenser_ACL_20201105T2213.zip (2.28 KB)

I’m attaching a couple days worth of failed attempts. Let me know if I can do anything else to help.
logs.7z (11.3 KB)

Thanks for posting your logs, Phileosophos. My colleague Markus thinks that your problems are caused by your computer’s clock being set to the wrong date and time: at the moment, it is expected that your computer’s clock will be within 1 minute of the real time. Could you please check your computer’s time settings and if possible enable synchronization with an external time server? If you’re not sure how to do that, here is a procedure you can follow.

oh my gosh, after syncing the clock SDA started. I think this should be fixed though.

I’m pretty sure that’s not what’s happening, seeing as the Windows 10 Pro x64 OS is set to sync time automatically, and the time on that PC is within 1 second of all the other PCs that are setting the time automatically. Still, I forced a manual sync of the time (which didn’t change at all) and then tried again and had the same problem. I’m attaching the log from my attempt right now.
Steinberg-Download-Assistant_2020-11-06_18-17-42.7z (2.41 KB)

Hamudi2000, I’m glad that fixes the issue for you.

Thanks for your logs, Phileosophos. I’ll pass them on to my colleagues in the SDA development team.

Any ideas? I’m still stuck here unable to download new purchases.

I am having the same problem. My time is correct, I have manually synced it 4 times now. I just spent a lot of money on Dorico Pro, I feel I should be able to access it. Please help me.

I need help. I have the same problem

I’m sorry to hear you’re having this problem, weberjonah10. You can always download Dorico 3.5 manually from this page instead.

Hello? Still stuck here having bought new products that can’t be downloaded. Any results?