Unable to move selected midi events

I have had this problem with Cubasis for a very long time.
When tapping SELECT to highlight a selection of midi events to be moved, then trying to move them to a new position just causes the selected events to become unselect and not move, but if I select the events using the Select tool as before, then turn the Select box off, I am then able to move the events to where needed.
It’s a bit of a nuisance having to go through this routine every time.
Is this a bug?
I have tried using the “Move X” “Move Y”, it makes no difference, as long as the SELECT box is selected then moving events is very hit or miss.

Hi @fixitmania53,

Thanks for your message.

Gave the issue a short check in the Arrange Window, MIDI Editor and Automation Editor, where things seem to work as expected (see the clips below).

If you still encounter issues, please share the steps with us to allow us reproducing the problem.


I have tried replicating what you have just shown in your clip, but unfortunately this does not happen in my Automation window.
My normal procedure is-

I open Automation, I select Volume for the particular track and using the pencil tool I add events where needed.
If I need to change the volume levels, I have to select any events to be moved, I then have to tap SELECT to to deselect it then proceed with moving the highlighted events.
But if I don’t unselect SELECT, moving any highlighted events result with them becoming unselected.

Have you been able to view my Dropbox clip?