Unable to Open Project: “Is a directory"


I was working on a Dorico project this morning. When I took a break, I quit Dorico, and now, when I try to open the project, Dorico won’t open it, displaying an error message that says: “Is a directory”

I’ve attached a screenshot of the error message, as well as a copy of the project file. I’ve tried opening older versions, both from my own backup as well as from Dorico’s own backup folder, but they all give the same error.

How can I open this file? Since older versions don’t work either, it doesn’t seem like the project was corrupted on save…

P.S. Unfortunately this is rather urgent — I’d really appreciate it if there’s a way to fix this quickly.
Screen Shot 2017-04-13 at 12.32.50 PM.png
untitled.dorico.zip (1.92 MB)

I get the attached error message when trying to open your project in Windows 10, so I guess your file has become corrupted. Don’t know if Daniel or the team can reconstitute it for you!

I’m the specialist on the audio engine side, but from that regard the data looks fine. Also with me here on Win8, I also get the error on loading. Sorry that I can’t help you further. Maybe someone from the London team can have a look, but you know, we’re all off for Easter break now…

OK — thanks for your response. I tried to submit a support request, but I am unable to — even though Dorico is listed in “My Products” in my Steinberg account, I can’t select it when I’m trying to submit a support request, and the field is required. This screenshot shows the issue.

Does anyone else have any suggestions? If I’m unable to open the file, I’ll have to re-do a whole day of work, which would be a real bummer…
Screen Shot 2017-04-13 at 11.50.12 PM.png

I just tried something:
As dorico files are supposedly zipped directories (with the .zip ending replaced by .dorico)
I renamed your file untitled.zip
Then opened (unzipped) it.
The resulting directory (folder) looks ok, as far as I can tell :wink:

But, if I zip (compress) that folder again, rename it back with the ending .dorico and try to open it, I will get the error „Error opening file: invalid file format“. That is a pity, otherwise one could have tried to replace the contents of another dorico file with your data, especially the file score.dtn …
By the way I tried the unzipping/zipping via context menu (on Mac) and via the terminal (unzip x and zip -r y z).
Dorico seems to use another zipping algorithm. I’ll try another zip tool, see what happens…
… no luck so far.

But if I open the file score.dtn with a text editor, I can see all your data probably being there ( I just peeked through, a vocal composition with libretto, leggiero…)

Julian, I am sure once software people are back from their easter holidays, your composition will be recovered easily.
contents of untitled.png

Thanks so much for doing this detective work. Too bad we aren’t able to re-zip the folder back into a Dorico project, but perhaps someone knows how to do that?

I did manage to replace the score.dtn component in your file with one from a healthy Dorico file, by way of the zip operation using WinRar, so this seems to indicate that it is the score.dtn bit in your file which has become corrupted… I fear the only hope is that the team can have a look and fix it…

Unfortunately it looks to my semi-untrained eye as if the score document itself within the archive is damaged. Check the ‘Backup Projects’ folder inside the ‘Dorico Projects’ folder on your computer, as hopefully it contains at least one previous save that will allow you to recover at least some of your work.

OK — thanks again to all of you for your help. Unfortunately all of the files in the “Dorico Backups” folder were also corrupted, but I managed to recover the last good saved file from my own backups.

In case it will help track down the bug that caused this, I’m attaching here three files:
• The last saved file before the project got corrupted (that is, the most recent file that Dorico can open).
• The file saved right after that (that is, the first corrupted one).
• The latest version I saved, which is also corrupted.

I’m going to re-do this work tonight or tomorrow, there’s probably no sense in trying to fix the file now, but I am curious if there’s any way to prevent this happening in the future. I suppose at the very least, I’ll close and re-open my projects once every thirty minutes or so, to make sure I don’t lose too much work if another project gets corrupted.
Last Saved (Corrupted).dorico.zip (1.92 MB)
9.51am (Corrupted).dorico.zip (1.91 MB)
9.49am (Good).dorico.zip (1.91 MB)

I can’t divine any clues from looking at these files, unfortunately. I will ask the team if they have any ideas on Tuesday when we’re all back in the office.

Is there already a solution to this problem - i´m stuck here, too.

Please feel free to send me your troublesome project at d dot spreadbury at steinberg dot de and I’ll do what I can.

In the meantime, check the ‘Backup Projects’ folder inside your ‘Dorico Projects’ folder to see if a recent backup in there can be opened.

For your information (maybe it’s mentioned before):
When opening a Dorico file today I had the same error “Is a directory”. Earlier I opened a Finale 25 file (Dorico was already running) and copied some text blocks. After saving the Dorico file was corrupt.
Perhaps it has something to do with the audio engine of both programs…

edit: I’m on a Mac

If you want me to take a look at your troublesome project, please zip it up and attach it here, or email it to me at d dot spreadbury at steinberg dot de.

Thanks Daniel,
It was a very small project, it was no problem to enter in again.
My post was just for information: possible problems using Finale and Dorico at the same time.
For me it was a learning moment…

There should be no interference between Dorico and Finale, and I wouldn’t expect running Finale to have any influence on what happens within Dorico. If you run into this problem again, do please provide your project so we can take a look.

Once a file or folder is named with a known extension, the macOS Finder itself (in most cases) cannot identify whether the opened file is a folder or not when you double-click on it. I suggest you to isolate your project file (not bundle folder or something, as Dorico project file shouldn’t be a macOS bundle folder) into a new folder and reperform your test.

I know Finale is terrible, but your current case is not related to that. Maybe (the possibility is really really small) your RAM data or SSD gets corrupted during your operation, and the corrupt is out of everyone can suppose.