unable to record midi

Hi, I have updated from Artist6.05 to 6.07, and now I find that i have lost midi functionality. Vst instruments will not record, nor external midi synth.
Audio Perfect.
Also, although, one can see midi data input on the transport bar when using external keyboard, no midi function whatsoever within the program…
Standalone instrumenst work perfectly. I have reinstalled artist and still no midi. I reinstalled Cubase essential 4, and all was perfect.
all drivers have been updated.
windows7 64 SP1, delta 44+audiophile 2496, 12 GB ram I7 processor 3.2GB

Any Ideas will be welcomed thanks.

How about simply checking all relevant MIDI settings…?


First of all try to check MIDI input/output settings.

Re-installation doesn’t help in most of case. Much more better is to trash Preferences. Reason is: new installation take the old settings over from the old installation.

Thanks to Martin and thinkingcap for their kind response. I have checked and rechecked all midi settings and preferences.
Even when I open a VST instrument and accept “create a midi track for the instrument” there is NO midi data at the input, when the VST instrument is playing.
If i try to control the vst instrument with the ext keyboard, although you can see midi activity at the input on the transport bar, there is NO activity at the midi device or track.
Midi-Port setup, shows input and output active.

In that case I can only think 2 possible reasons for your problem:

  1. You have not selected right MIDI input for your track.
  2. You have not pressed the “Monitor” button on.

Thanks Jarno, but monitor is pressed on.

Hi downside - apologies if you’ve already done this:

  1. Try setting your MIDI track input to “All MIDI Inputs”. Maybe for some reason currently your MIDI is going out on one channel, but your MIDI track is looking to another channel for its input?

  2. The “monitor” button Jarno refers to - I hadn’t thought of that as an option - but I know that sometimes it’s not clear that it is the tiny white “speaker” button in the track inspector that turns yellow when you press it. There can be many “monitor” buttons in our systems!

Since you see MIDI IN activity in your transport bar, you are 90% of the way there - it will happen soon!

Setting’s in Prefs. :unamused:

Yep, forum’s gotting less intelligent.

Might be corrupt preferences as Martin.Jirsak suggested. See step 2 here on how to find and hide them:


Thanks for the input Alexis, all ideas are welcome.
I have been using Cubase since the heady days of Pro24. I have never come across this before. I have also looked for all the stupid omissions that come with age. I reinstalled Cubase essentials 4 and it works perfectly, so I ruled out the midi interface.
Of course, Cubase 4 is 32 bitversion. but I have been running artist 6 64bit without a hitch since it was released,this only happened when I updated.
kind regards.

Emil Hannson,is Top Man, thank you so much.
That was the problem. I was too thick to understand what Martin Jirsak was correctly prompting me to do.
Thank all you guys so much for your help.