Unable to Render in Place

hi guys I’ve been having issues with several thing right from the start. Although I just upgraded today from Artist to Pro 12 I’ve been having this issue since I purchase Cubase a few months ago.
I’m unable to Render In Place audio or Midi. The progress dialog never shows up. Any clue what might be going on? This isn’t the only strange thing that isn’t working correctly. I have also had an issue not being able to save a project as a template which I have another post on.

This is a video of what happens when I try and Render a midi track in place.

I almost always use Instrument Tracks and only rarely MIDI Tracks so take that into account in this response.

Not totally sure but it looks like you are routing the MIDI to an external synth? I think (and again I’m a bit iffy on this) for that to work you would have to create an External Device for the hardware synth. That would let Cubase know where the audio from the synth is coming from. If you are just sending MIDI data to some hardware it’s not really associated with any audio so there is nothing to Render. Of course you don’t actually need to Render if you don’t want to make an External Device - you could just record the Audio from the synth like you would someone playing it live.

You also mentioned problems with rendering Audio - can you give an example?

1 Like

Hi Raino.
Hmm that makes sense. So I guess every time I’ve seen somebody Render In Place they are using an internal synth plugin? I have always thought to myself “how is it taking the midi data and getting the audio from the data without any audio playing or being heard?” That’s how. So when it comes to rendering midi data to audio using an external synth…in this case my Yamaha P200 stage piano I would have to first create this device in my midi devices then should this as the port and it should be able to do the rendering? But with the device being external how can it get audio from the midi data without it actually play the track?

I looked for my example of render audio and I’m actually thinking about something else not rendering to audio. Sorry about that. I’ve had several issues but I confused two of them together.

Hmm I’m confused…again. So I set up a midi device in the Midi Device Manager and set the channel, etc. But the rendering still doesn’t work. I’m not so sure it’s suppose to work this way. The manual says that the things that can be rendered is “MIDI parts on Instrument Tracks”. I assume they mean VST instruments?

Is there anyone that can confirm that rendering a midi track to audio is only possible if the midi data is NOT connection to an external synth, stage piano, etc.?
Thanks guys

Sorry guys…this learning curve is steep for me.
C

Render in place will render ‘audio’. So it will work perfectly on an instrument track because this outputs audio internally in your DAW. But It wont work on a midi track because midi doesn’t output audio. You’re on the right track but what you need to understand is that for rendering audio you need audio input…
It depends on what you’re aiming to do? If you want to use a VSTi to render audio. Stop messing with midi tracks and load as much ‘instrument tracks’ as you need with its own instance and render from there.
If you need to render an external instrument, its an entirely different story…
Then you need to go to external instruments and set up your instrument there and configure what ‘audio input’ (coming from your synth ) you would like to connect to what ‘physical’ input on your audio interface. Once you’ve saved that you’ll be able to open your device as an ‘instrument track’ ( a restart of Cubase may be necessary) and this will allow you to record or render in place the audio coming from your external synth into the physical inputs you’ve configured for your audio device.
I can imagine this sound complicated but you must always realize that an ‘audio render’ always needs an audio input to be able to do this. Midi is data that controls devices to do what you want, it’s not audio. Hope this makes sense?

1 Like

You obviously cannot do that with hardware instruments…

Hardware synths are outputting audio in real time through audio cables, the only way to do that is to send the MIDI data by playing the MIDI track and record the audio track at the same time.
If your sequence is one minute long then you’ll have to wait one minute because the synth will be played in real time, just like when you play it manually.

There’s not such a thing as render in place for hardware instruments, even if you add it as an External Instrument under Audio Connections. External Instrument in Cubase act like physical inputs except you have more control over it than standard Inputs.

Lol this post wouldn’t be here if it was obvious to me. Although when I was watching all the videos on this feature it got me thinking. Since Midi is data not audio but I never noticed that everybody that is using this feature is using VST instruments.
Yes I do understand MIDI and I could play the track and record the audio from the external instrument. Yup. I guess I’ll have to do that.
Thank you
C

hey thanks for the input on this.
Yes it honestly makes total sense to me why it’s not working NOW. I never noticed all this time I was seeing people use this feature that they were all using internal VST instruments. I have 6 external modules/keyboard/controllers. So A lot of my stuff is external. I guess the only way to “render” the audio is to play it in real time and record the audio coming back off the external instrument then… Ahh! Although I’ve used a DAW before it was back in the 90s so a lot of this is new to me. It’s been a bumpy ride so far.
I did create (in Midi Device Manager) my Yamaha P200 piano but can’t seem to understand if there is something else that needs to be done.

I added a VST instrument track to this project. I then copied the midi data to this track. I rendered in play and it worked but the first time I did this I heard audio blasting very quickly (not real time) as the progress bars progressed…the second time (and every time after this) it was silent. Why is this?

You don’t necessarily need to copy the midi notes to the instrument track.
On your midi track, just select the instrument track as the output. You can route as many midi tracks as you want to a single instrument track. When a midi track is routed to an instrument track then you can directly use render in place on that midi track.

Also this is quite bizarre that you heard actual audio during the render in place. It’s not supposed to make any sound. This may be a bug.

1 Like

Louis,
Thanks man.
Yup ok cool…just switch the output of the track to the VST instrument I want to use. Got it!
I’ve had quite a few bugs with Cubase so far and it’s scaring me. I haven’t yet found a work flow because I’ve been crawlin’ in the mud since I started using it.
I can’t save any project as a template…one of the other issues. I can’t get sound out of Halion SE. Every other VST works the moment I enabled in the track but not Halion. I’m trying to reinstall the VST and it’s content using the download assistant but wow this has been a real painful experience so far.

No problem Christopher !
I know Cubase learning curve is a bit steeper than other daws because it is more complex, but once you start getting used to it, it works flawlessly.
There are a lot of issues with Cubase currently but fortunately the developers are working hard on it.
A lot of updates are expected within the next few months so don’t forget to install them when they get released.

Good luck !

1 Like

Render in place for external keyboards is just real-time record the inputs. For it to work it would need to know where to send midi (it would know this anyway) but mainly which audio inputs to record from. I suppose if these were tied up together it do it automatically (in real time though. No short cuts for real audio)

1 Like

Thanks man! Yeah it is steep but I’m here with Cubase because I see it’s capabilities and support from the user base which also means that colaberation between users (with projects) is also better and more likely. I’ll stick it out for sure but all these years I’m struggling with finding…or making time to work on two decades worth of projects. Right now I have nothing to show for it but my intention is to change that. Just recording alone is overwhelming, never mind the production side of things. I hope things change so I can build a little confidence in being able to see the light at the end of this tunnel. Being productive hasn’t really happened yet but I’m hoping this will change soon.
Thanks again Louis for your input, time and help with things. It’s very much appreciate!
C

1 Like

Hey Mk
Yup all of this makes a lot of sense. This is another thing I thought worked one way and I was dead wrong but I understand what you guys are saying about this and it makes perfect sense. I just remember seeing the rendering of midi to audio on some videos and thought “wow…that’s sick!” I thought it would save a lot of time but everybody is using VST instruments. Although I will to I have a lot of external gear…mostly because I was doing this before VST were the norm.
Thanks again for taking the time to explain things. It’s very helpful.
Chris

1 Like

Midi manager has nothing to do with receiving audio from your Yamaha P20. You need to create it in ‘external instrument’ and assign the physical outputs to which your P20 is physically connected to your physical ports on your audio interface. And yes, recording external instruments always will be real time because your recording analogue audio coming from the outputs of your synth into the input of your audio device. So dive into the ‘external instruments’ and make sure your physical audio output from your synth is connected to the physical input of the physical input on your your audio interface.

1 Like

Hey Nickeldome,
Wow. It was like getting hit with a cinderblock across the face…again! SMACK! The more I work with Cubase the stupider I feel and realize this will be a long long road before I’m productive I think.
I just set all of that up now. My error it’s a Yamaha P200 stage piano. I just set up all of my external midi devices. Although I set them all up along with the midi side of things it’s hasn’t “clicked” so I’m going to go back there an understand the connection between these settings. Thank you for your input.
C

Hi Christpher. You shouldn’t feel stupid! It’s just not easy to grasp these concepts when you just starting out using them. As a test or exersise you could also create a stereo input track and use the inputs where you P200 is connected to. Then create a seperate midi track and record something that is send to your P200. Now try to record/render the audio that comes from your P200 on the audio track you created earlier. This principle is the same as using an instrument track. But using the instrument track is easier because you just have to load the vst that was created there and this will take care of the midi as well as audio on one track. Just like any other vst intrument. But again alway realize that audio from a analog input always needs to be recorded in real time. Good luck.

1 Like

Thanks Nickel,
Well the reason why I feel the way I do is because this isn’t that new to me. Although I never had a DAW is this level I did use Cakewalk in the 90’s with midi only. I’m struggling with ADHD and Im’ sure this is only adding to the trouble in this area. I’ll try what you said and others and try to take it one step at a time. I have some tech issues I think with WIndows as well. I think I may just wipe the machine and start over to ensure this tech issue isn’t contributing to my problem.

Yeah I now have a better understanding how this all works when it comes to external instruments vs VST instruments. Thank you and I’ll work through this. Thanks for your time and help n this. I really do truly appreciate all the input from everybody.
Chris