Unable to switch Audio Cevices

Hello Everyone

I am using Dorico 3 (3.0.10) on a Mac (10.12 Sierra). Since I upgraded to Dorico 3, I get no Audio. When I open the “Device Setup” in order to change (or verify) my Audio Device I am unable to change the Audio Device (e.g. to build-in). In Dorico 2 everything is working fine. Did anyone encounter a similar problem? As playback Device I am using Noteperformer.

Regards to everyone

I have the same problem :frowning:

I have a similar problem. Often when I start up Dorico 3 I have to go to Play -> Edit -> Devices and change from Built-in Audio to Stereo output (via iMic) or vice versa before Dorico plays. Before that, the carat doesn’t move though the green play arrow lights up. When I get the play started again through changing the device, I often get a sudden burst of sound as all the notes it tried to play exit all at once!
Sometimes I have to change the Playback Template to Elements and back again to get the sound output again.
I haven’t reported this before since I have always managed to get it going again - and am hopeful that the next update will sort it.

@Henrik and Kammerjunken, do you only run Dorico 3 and not Dorico 2 in parallel? Could you both please open a simple project and then do ‘Help > Create Diagnostic Report’. That creates a zip file on your desktop, please attach here.

@andyforest, that is an area that we have been working on, please wait for the upcoming Dorico update.

Thanks Ulf - no probs.

This is the Diagnostics File. Hope this helps to find the Problem.
Dorico Diagnostics.zip (1.38 MB)

Thanks for the data, Henrik. It’s really weird. From the logs I can see that 4 audio devices get recognized, but even if you try to switch to another one, it always immediately falls back to your “Digidesign HW (003)” again. I don’t really know, never seen this before.
But sound does come through your Digidesign device then, correct? Have you tried disconnecting that completely? Still same?
Also, there is an xml file under /Users//Library/Preferences/Dorico 3/preferences.xml (all just from my memory, could be wrong).
You can load that file into a text editor and pretty much at the top you’ll find Digidesign set as your preferred audio device. Change that to Integriertes Audio Gerät, then save and restart Dorico. Does it get any better?

Thanks a lot. Disconnecting the Device. Helped