Unable to switch to another audio output in Cubase Pro 9.5.3

Hello. I am currently using Cubase Pro 9.5.3 and my Cubase can only playback from my built-in speakers.

It was playing from my headphone when I was first using it, but after I have plugged out my headphone once while playing the tracks and it automatically switched to built-in speakers once, the audio output settings could not be changed even I restarted my computer and re-installing the software. When I was using Cubase in my previous Macbook Air it could detect the audio output automatically and switch it without any problems.

When I was trying to change the audio device in audio connection settings, it cannot detect my external headphone and it can only playback from speakers. But my headphone worked perfectly fine while listening to tracks in my computer, youtube or soundcloud etc.

I have tried switching between different headphones such as Sennheiser HD660S with/without amplifier, Audio Technica ATH-M50X and earphones such as Final E5000 and Thecoopedia Beans (bluetooth) but it still cannot detect my external audio outputs. How can I solve this problem? Thank you very much!

These are the specs of my computer
Macbook Pro 15-inch 2018 running on High Sierra ver 10.13.6
Processor: 2.6 GHz Intel Core i7
Memory: 32GB 2400 MHz DDR4



Hello,

I hope it is OK to post in this thread as I have the same problem:
Macbook Pro 13inch 2018 on High Sierra 10.13.6

When I plug in my speakers in the headphone jack, Cubase continues to use the internal speakers of the laptop. The OS and all other apps change to headphones, only Cubase does not.

I compared to my old Macbook Pro 2014 running Cubase 7.5 which does not have this issue. These are my key observations:

Old macbook: Plugging in something in the headphone jack REPLACES the internal speakers (in MacOS Sound Preferences and also in Cubase ASIO driver view). So there is always only one output. All fine!

New macbook: Plugging in something in the headphone jack ADDS a new output (in MacOS Sound Preferences and also in Cubase ASIO driver view). In Cubase both outputs are named the same: “built-in audio”. Switching between them does not change anything.

I am grateful for any fix or workaround.



To the OP, have you tried selecting the second “Built in Audio” option in the ASIO set-up window from your first screen shot?

I have the exact same issue! PLS HALP :’(

I have opened a support ticket with Steinberg some days ago. So far no response. I think this is a general problem with the new 2018 Macbooks, so hopefully enough people will complain for a fix to be released soon…

The reply that I got did not help at all… I can only warn anyone from upgrading to MacOS 10.13.6. Cubase isn’t ready for it.

In this case, you will have to configure your audio connections:
https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/vst_connections/vst_connections_window_r.html?hl=vst%2Cconnections

In any case, we recommend the use of an external professional audio interface:
https://www.steinberg.net/en/products/audio_interfaces/ur_rt_series/ur_rt2.html

Support told me “its not possible to do what you want to do” and the only solution would be to buy their audio interface. Pretty disappointing.

Finally, I found a workaround that seems to bring everything back to normal. It involves creating an aggregate device of speakers & headphone jack. Let Cubase use that and continue using the normal audio in the OS (If you use the aggregate in OS, you cannot use the volume keys anymore).

Dude, you’re the man!! Your workaround works perfectly! Thanks for the tip!!

Steinberg support are a joke. They think ignoring our support tickets makes the problems go away. Terrible customer service. At least come out and tell us you’re working on a fix but haven’t got one yet. Pathetic.

Hi,
can you tell me how you created that workaround?
I have the same issue on brand new MBP 15.

I’d really appreciate instructions too… Thanks!

It is simple:

Audio-Midi-Setup: + new aggregate. check speakers and headphones. Source should be speakers. Don’t forget to look down in settings and activate this new aggregate. that should be it. Works well now for me

Does Cubase really work on a Mac totally … software issue free
Day one ?? It’s not working for me sadly. I wanted to get the top Cubase software I’m not so sure now all the software breakdowns I had and I also see here. I hope they get it working for Mac a lot better then this. I’m feeling windows might have less problems. Till then I’m waiting before I upgrade.might just stick with GarageBand it works hassle free yes it’s missing a few top end things but it works right out of the box. Home run. I wish someone could have helped me or it worked hassle free Cubase but mine could not find its own sound files so no sound

You may be having this problem:
https://helpcenter.steinberg.de/hc/en-us/articles/360000931359-Mac-Unable-to-switch-between-speaker-and-headphone-outputs

The aggregate workaround is described here as well. Apparently they’re working on a fix.

UPDATE: Fix issued with 10.0.20. No more aggregate workaround necessary.