Unable to upgrade firmware on UR44

I have been trying to upgrade my UR44 firmware but am constantly getting the message “Error: UR is not detected.
Please check the connection and reboot this software”. The interface seems to be working as the output and input signals are getting routed fine ( I use Cubase, but used Garageband and CubaseAI to verify this). One strange thing is I am not able to access the console for UR44 using either the Steinberg USB control interface or through Cubase. Anyone knows whats going on?

1 Like

Hi,

same problem here.
You must deactivate the CC mode and restart the UR44
that works for me.

Greetz

Waht is the CC mode?

It is a little switch on the backside turning the CC mode on and off.

CC mode is for using the Interface with an iPad

Thansk a lot … my UR44C has no such a switch :grinning:

we have the same issue with the UR 24c tried it with power supply through USB and through power adapter. same result both times. Any other ideas ?

Thanks for the responses. A quick historical update since that last post 4 years go. Turns out that the UR44 at the time could not be upgraded using my macbook. I invariably had to connect it to a windows machine (which i borrowed) and upgraded the firmware using that. A little strange that OSX wasnt on the list of OSs that supported this upgrade procedure. Havent faced an issue since then (happy owner of the UR44 for 4 straight years now) .