Unchecking of Flows deletes complete score of Flow

I’ve been working on a new piece that contains several movements (flows) for a week now. Because I found it annoying to have all the movements visible and I often didn’t find the bar I was looking for (too many pages to scroll through), I unchecked the flows that I didn’t want to see in the Setup Panel. To my understanding this would simply hide those flows. But apparently the complete musical input will be deleted by doing so. :confused: I just clicked on the checkbox of a completed flow in order to get back to it, but there are only rests, all the music is gone. :open_mouth: Is this really what should happen when you uncheck a flow?! Is unchecking really supposed to delete everything? I’m afraid that Dorico does not create automatic backups yet, does it? :cry:

Is it possible you clicked the check boxes in the Setup Panel, and not in the Flows panel (with layouts selected)? Here’s the corresponding doc text:

To exlude Flows from a Layout (so you don’t see it) http://steinberg.help/dorico/v1/en/dorico/topics/setup_mode/setup_mode_flows_from_layouts_excluding_t.html

To remove an instrument from a flow (what it sounds like you did)
http://steinberg.help/dorico/v1/en/dorico/topics/setup_mode/setup_mode_flows_c.html

Thank you, Steve, for taking the time to send those links.

You can exclude any flow from any layout by deactivating the respective flow card.

(source)

That’s what I did: I deactivated the flows by unchecking the tick box on the flow cards.

The same document says:

All players are added to the new flow. You can exclude players from the flow by deactivating the respective player card.

Important:
If you exclude a player from a flow, the notes that you may have already input for that player in that flow are deleted.

I don’t remember having clicked the check box in the Players Panel, but who knows…

But I was definitely able to reproduce that deactivating a flow in the flow card makes the music disappear (1. uncheck flow containing music, the pages disappear, 2. check the same flow again, the pages reappear, but all the music is gone, 3. cmd+Z to undo to get the music back).

Whatever happened, the music of the flows that I deactivated some days ago is gone. If this is Dorico’s expected behavior, it should definitely warn the user when you uncheck something that the music will be deleted, so that you have to confirm this step before any damage can be done.

Maybe it’s also a weird bug causing these problems? Now when I look at the Flow cards, there are no check boxes anymore:
Screen Shot 2016-11-09 at 19.25.04.png

The checkboxes appear when Layouts are selected.

Oops, I wasn’t aware of this, but of course, this is logical. Thank you, Steve.

:smiley:

I would like to post a few screenshots to clarify my problem.

  1. Flow 2 is checked. Everything ok so far.
    1.png
  2. I uncheck Flow 2.
    2.png
  3. I click the checkbox once again. All the music is gone.
    3.png
    In the Layouts panel on the right side, “Full score” and "Piano“ is checked. I just don’t get it. Why does Dorico delete the music?

On my system the checkboxes on the flows also appear if no layout is selected on the right, so if I deselect and reselect, the music is lost. However, as long as a layout is selected (appears blue) on the right, it works as expected…

Davidusmusicus, your screen captures don’t show us enough information. We can’t see if anything is actually selected in the Layout column. It may appear as if there is something selected, but if the color is not a bright blue (at least in my installation that’s the color, Win10) then it’s not really selected, no matter that it might have a darker blue highlight on it.

I just did a bunch of tests on a sample score I’ve been using for these experiments, and when I open a project and go immediately to the Setup screen, it appears as if there is “Full Score” and “Violin” checked in the Layouts column, but that is deceptive. That is a dark shade of teal-green and does NOT indicate that they have been selected. See the first attached file. If I then uncheck the box for the flow in the bottom panel of the screen, the flow disappears and when I re-check the box to have it show, it reappears but there is no music in the violin part.
1.png
Then when I actually click on the word “Full Score” in the Layouts panel, it turns a brighter blue (see my 2nd attached file) and then when I uncheck the box for the flow, it disappears and when I re-check that box the flow reappears and all the music is intact.
2.png
I think this screen needs to be reworked so that it is more clear that when we first click on the Setup panel, the color should not be any shade of blue or blue-green. It should be very different, like dark orange. That way it will be clear that it hasn’t been selected, it’s merely giving us information. Then when we select it it should turn bright blue, as it does now, so that it is dramatically different.

I know what’s happening – when we click on a different Player in the left-hand column, whichever Layouts that instrument appears in are highlighted in the teal-green color which means it’s giving us information but isn’t actually selected.

It depends which checkbox you used. Removing a flow from a layout doesn’t empty the flow, but removing a player from a flow removes the music that player’s instrument(s) had in that flow.

So to prevent a flow from appearing so that you don’t have to look at it, but to preserve the contents of the flow: select the layout in the Layouts list so that it is bright blue and you see the checkboxes in the Flows panel. Switch off the checkbox(es) for the flow(s) you want to remove from the selected layout. In this case, the music is all still safely there, just not shown in the selected layout.

To remove the music from a flow, by contrast, select the flow in the Flows panel so that it is bright blue and you see the checkboxes in the Players panel (and indeed in the Layouts panel, though that edit is not destructive so you don’t need to worry too much about it). Now if you uncheck any of the checkboxes in the Players panel, you are removing the music for that player from the flow. This is a destructive edit. It should of course tell you that it’s a destructive edit, so we will address that as soon as we can.

That’s all clear. What I (and perhaps the OP) was referring to above was:

  1. start a new project - enter some music.
  2. return to SETUP mode (no flow or layout is highlighted)
  3. Don’t click/activate the flow box, just click its checkbox in the upper right corner. The flow disappears.
  4. click the checkbox again. The flow returns, but the music is gone. It’s all rests.

not purposeful or logical, but things that can easily happen as one explores a new application :slight_smile:

Indeed, I can confirm. If an item in the Players list is highlighted- as it is when you first switch to Setup mode or, if you click on one- the checkboxes in the Flows are available, and deactivating one removes the flow and deletes the music too.

Yes, that’s all to be expected: as I explained above:

When you switch to setup mode, one of the players in the Players list is selected (i.e. bright blue).

Thank you, guys, for all the comments, and thanks to Daniel for explaining what exactly goes on there. I hope that I was the first and the last user to have lost many hours of work because of this very strange and unintuitive behavior. :wink: Clicking on a checkmark should never delete any music. (Fortunately the music is still in my head and I will be able to reproduce it.)

Perhaps I have misunderstood, which is highly likely! I thought we were saying that unchecking a checkbox in the Flows panel deletes music, whereas Daniel is talking about unchecking a check box in the Players panel.

Right, Steve… I think I have misunderstood. This whole thing should be much clearer. I definitely lost my input by clicking the checkboxes of flows and not in the Players panel (which I was able to reproduce).

Indeed. Here’s an animated gif of what I’m seeing. It shows that unchecking a checkbox in the Flows panel removes the staves, and rechecking it returns the staves, without the music. Is this the correct behavior?
uncheckFlow.gif

any program choice that could result in the loss of music should at least pop-up a warning and give the user the choice of continuing the operation or not.

Yes, Daniel noted this as well.

It is, yes. All of these relationships are bi-directional: if you have the flow selected (bright blue) and uncheck the checkboxes in the Players panel, you remove the player from the flow and thus delete that player’s music in the flow; if you have the player selected and uncheck the checkbox in the Flows panel, you again remove the player from the flow and thus delete the player’s music in the flow. It should obviously give you a warning about it.