Understanding CPU load

I’m trying to understand the CPU load in Cubase 11 Pro. Having a 24bit/96kHz project with a quite low latency configuration (128 samples, 4.5ms), with just some VST my powerful computer starts to glitch and crack. My windows resources are not so stressed (just 10% of real CPU). How the Cubase CPU load and the OS are related? The manual says that the multicore option is the default.

1 Like

I think the manual probably has a good description for the meter in Cubase and Nuendo. In a nutshell I think it computes how much “headroom” there is left processing audio on your computer. It’s not the same as the Task Manager CPU load since the Task Manager doesn’t take into account that we need fast realtime performance to prevent dropouts.

So if you have for example a 10-core CPU and you load up one audio track with a ton of heavy plugins and you have no other tracks then it’s likely all of those plugins will process in series and load one core. So you can run out of processing power because that one core is heavily loaded but to the operating system it’s looking like you’re only using 1/10th of all resources because the other 9 cores aren’t doing much.

Makes sense?

You can test this yourself by loading up one long serial chain and then instead try loading in parallel using many tracks and groups etc.

1 Like

Hello mmoreo,

There is a function in the mix console that may help you narrow down what is taking some of your latency. Only works on channel inserts so it will not help with any heavy VSTi’s you may have in your project. On the top left of the mix console click the “Setup Window Layout” icon, then check “Channel Latency”. You’ll get a little window above each channel that will tell you how many milliseconds are being taken, you can click on that window to show a more detailed view. See attached pictures, shows my main output channel with the Brickwall Limiter inserted taking 1.0 ms.

Hope this helps,


Thank you, I’ll do some tests. Understanding how Cubase uses the multi-core architecture is the key point before spending more than 2k€ for a thunderbolt interface. I need low latency for plugin-based guitar and VST-based drums recording, so I’ll pay attention to any advice on the matter.

Not completely sure about this, but crackles on one insert-overloaded track may be eliminated by transferring some of its inserts to other Groups and FX tracks, then sending the originally overloaded track to those Groups and FX tracks.

Wow, just a new 24bit/48kHz project with a single stereo guitar track with a Neural DSP plugin, the Cubase CPU it’s gone. How is it possible?

Following @xerogh suggestion, the channel latency is 0.1 ms (4 samples). wtf?

Are you getting crackles and drop outs?

If not, maybe best not to worry despite what the Cubase monitor shows, until/ unless you actually start hearing problems.

@alexis unfortunately that’s not the case, sometimes the sound stops. It makes no sense, my CPU is very powerful and we’re talking about a single plugin. I hope there’s a solution :disappointed:

Can you provide more details about this “powerful computer”?

If you need low latency for real time guitar sims and drum MIDI recording it is highly dependent on your audio/MIDI interface and drivers and how they interact with your mysteriously yet undefined “powerful computer”.

In this case, more speed is generally favorable over more cores (from what I understand).

What is your currently used ASIO audio device?

Also, there is this you can try …

Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks

Im fairly confused, and I am stunned that this issue is obfuscated in this way.

Ive been following this IDENTICAL issue, and have made dozens of posts about it, since cubase 10.5, and I have confirmation of the issue (ASIO internal overload from hyperthreading/multi-media multithreading) from steinberg in writing via email.

I keep seeing this over and over, 1000s of times since last year alone, and each time the response from steinberg is “have you checked the manual/do you know how to admin a computer/have you bought new hardware/have you replaced all your hardware”. Nearly 100% of the time.

And each time, as I follow these threads and notice the much larger megathreads about the issue, I see the same pattern of customer service and it frankly enrages me.

To the OP:
Have you tried any BIOS changes, such as totally disabling all virtual cores, disabling all CPU p-states/power management, and disabling all dynamic clock frequency(speedstep, etc) features, then try this again?

I have seen the identical issue 1000s of times, Ive seen it on windows and mac over the years, and I have seen it on $10,000 workstations as well as $2000 workstations. I have a $1200 laptop that does not experience the issue because of a specific BIOS feature set that MSI built into that unit.

Perhaps the $1200 MSI laptop from 2017 is the “powerful machine” that Scab_Pickens means.

Im not sure if there is a 12.0.30 megathread on this, but here is the megathread for this issue for 12.0.20.

It might be helpful to review this thread. Hope you are able to work around this.

The problem is not average CPU load.
The problem is what your system interrupt latency is.
A vast variety of devices in a system have been known to lengthen the interrupt latency by milliseconds at a time, and if this happens, no sound card is going to be able to play back without crackles.
Some graphics cards do this.
Some network cards do this.
Almost all BIOS / RGB / system-monitor / SMBus tools do this.

They do this, because it’s either the easiest way to write the driver, OR because it leads to higher benchmark numbers in whatever benchmark that particular vendor is optimizing for, even if the overall enjoyment of the system goes down.

So, rip out anything you don’t absolutely need. Uninstall all drivers and add-ons.
Update BIOSes, both for your motherboard, and for each device (including graphics cards!)
See if it gets better.

Run a system latency (interrupt latency) monitor.
Sometimes, you have to break out the windows driver developer kit software to debug the system, and if you’re not a systems software programmer, well, you’re kinda SoL then…

This may be helpful, @mmoreo :

Unofficial Windows 10 Audio Workstation build and tweak guide - Part 1 - Windows MIDI and Music dev (this is one part of three, generally applicable to W11 per the author)

Also the latency mon link by scab-Pickens some posts up may point you to some processes you can turn off. Would run it for a long time, maybe overnight before checking results.

Also using latest versions of plugins, hardware drivers, check specific plugin forums to see if others have similar problems.

Finally, turning off things like WiFi, antivirus, anti-malware, windows “indexing”, cloud sync (like Microsoft OneDrive), back up programs, basically anything else you can think of that might divert the computer’s attention from real-time audio.

Having only the necessary tracks being record-enabled can help.

Finally, if you can run it till it crashes, sending a crash dump file (instructions on one of the other current threads) may point out the problem.

Sorry if you’ve done all this already, don’t mean to post things that may be obvious already to you!