Understanding MainOut and Out2 in Halion - please help

I made a simple sheet in Dorico with two paino players.
In play mode I assigned Channel-1 to Pno1 and Channel-2 to Pno2.

In Halion I loaded two GrandPianos (two slots in the Rack). Slot1 is set to channel A1, Slot2 is set to channel A2.
It seems to me that is right way to setup two independent piano sounds for Dorico. But I am not sure if this is the correct way.

My question is about the output of Halion.
Slot1 is set to Main
Slot2 is set to OUT2
This works in a way that I can solo each paino in Dorico Playback. So I can listen to PNO1 or PNO2 independently.
So far so good.
But, I don’t understand why it is working.
I am not clear about the relation between the MAIN and OUT2… in Halion and the PNO1, PNO2 sliders in Dorico’s Playback Mixer.
Unfortunately the “Dorico First Steps PDF” only tells me to use the Playback Template but does not explain the Background of it (but nevertheless the PDF helped a lot to get me startet with Dorico).
Is there maybe also a “First Steps Document” about this channel and OUT stuff?

Dorico-chain_06

Dorico can’t interrogate HALion (or any VST instrument) to determine the routing that’s set up inside the plug-in. So it assumes that input on MIDI channel 1 will come out on output 1, input on channel 2 will come out on output 2, and so on. If you apply one of Dorico’s default playback templates, it will automatically apply a saved plug-in state to HALion to ensure that the MIDI channels are mapped to outputs in this way.

@Klimper ,
My recollection is that (at least in some Steinberg products) Out 1 is labeled Main. Why? I do not know–and it did confuse me some when first assigning channels from Kontakt and the like–but whether this is a quirk at Steinberg or an industry standard I am not aware of, it is just something to note down in my memory and get on with my work.

Ok, let me try to understand:
MAIN in Halion is not like MAIN in an audio interface. I know MAIN as a Master Channel that takes all the individual audio signals and sends them to the final output (e.g. Loudspeakers, Headphones).
In case of Halion MAIN is just an output channel like all the others (thanks @Derrek ).

If I create two pianos in Dorico with Midi Channel1 and 2, send those two into Halion then Dorico expects to get the audio back from Halion on OUT1 (=Main) and OUT2 - ist that right?

Dorico then sends the audio from those two to its own MAIN Out (the slider on the right in Dorico’s mixer) - is that also right?

If - for example - I like to have Piano2 on OUT3 in Halion, I would need to assing Channel 3 in Dorico.

If I understand that correctly, there is no free routing of the signal possible in Dorico. If it outputs to Halion on Channel1 it wants the signal back on OUT1.

Did I understood this right?

One can select output channels in the HALion panel (and in many other VST’s).

Yes, I found this but it seems Dorico does not know about this change. E.g. if I input Piano2 via channel 2 into Halion, but then change the output of Halion to OUT3, Dorico still expects the signal on OUT2. So Halion can route the signal but Dorico does not follow this routing.
I understand it as a fixed link in Dorico - like: if Channel OUT in Dorico = 2 then Channel In from Halion = 2 (OUT2) as well.
But I can’t find any related information in the manual or the first steps pdf confirming this. Only the post from @dspreadbury indicates Dorico is working like this.

If you change the Halion Out2 to (say) Out7, it will arrive in Dorico on an Unused Channel called HalionSonic7, which seems pretty reasonable!

Ok, so Dorico does get all the channels back from Halion. It is not a fixed relation like I thought. I just need to know, to show the channels in Dorico’s mixer (arghh, stupid me).

May I ask another question:
If I start the playback, Piano2’s level is always set back to zero. I can manually increase it in Halion while the playback is active, but next time I start the playback it is zero again.
Do you know where this “set level to zero” comes from?

Not sure if it’s the same issue, but this bit me with Ampel Guitars: The default expression map has only velocity as volume dynamic. You should either apply the proper playback template (HALion Sonic Sel.) or duplicate the default expression map, rename it and add CC7 (or CC11., not sure how HALion manages this) as secondary volume dynamic for Natural. Then, change the Ex. map from the drop down.

If (as I suspect) HALion works like the Garritan Aria Player, it responds to changes in dynamics notated on your score. So if the music starts with Pno 2 not playing, finding the HALion mixer set to zero would not be surprising. It would likely respond as your Pno 2 starts playing and changing dynamics.

One should set the base volume for a player in the Dorico Mixer, not the HALion Mixer.

I think you are making things more difficult for yourself trying to micromanage the program. If you use the Playback Template to set your instrument disposition (and if you are still missing the templates, that is a problem you should work with Dorico Support to solve) and worry more about the Dorico Mixer than fussing with HALion at this stage, you will save yourself a lot of needless worry.

That was because of not installed extra content.
But I am actually happy about not having had the templates in the first place. With your help I understood how it works and can now make my own playback instead of being bound to templates. And this advanced stuff like expression maps, well, more stuff to learn.

Thanks for your support guys.

Yes, it’s probably coming from the corresponding MIDI channel in the Dorico mixer. If you click the MIDI button on the Dorico mixer that will reveal all the MIDI channel faders. My guess is that the fader for the corresponding MIDI channel is set to zero. Dorico chases this and will send it out whenever you hit play.

Very likely - I have overwritten that little project I made for my first steps in Dorico, so I can’t check it anymore, but I remember that I changed the midi sliders inbetween. Thanks for the hint.

Dorico knows a little more about audio routing when using the built in templates, or reusing user templates that you’ve set up and saved.

However, if you start some instance of a plugin from inside the play tab, and go about making your own custom setup, the plugin might need some manual adjustments to go beyond a simple ‘stereo mix’. In fact, some plugins can’t do multi-output at all.

Dorico hides mixer channels that don’t have staves or voices directly assigned to them. You can still see and use the hidden channels with quite a few plugins out there if you tick ‘unused’ in the mixer.

I.E. sometimes with something like HALion, I like to route the ‘aux effect’ busses off to an isolated set of outputs in HALion (as opposed to having it all mixed in with the first violin slot on the Main set of outputs).

Since no ‘player/stave’ is assigned to this directly in Dorico, it doesn’t show in the mixer until I click that ‘unused’ button.

In this string quartet arrangement I’ve modded up my own custom HALion HSO sounds with full HALion. I’d like to use HALion’s built in effects on the AUX effect sends, and isolate them to a unique fader of their own in the Dorico mixer like this (with my effects mix coming through HS Out 6)…




For instrument slots of which Dorico has a player, or stave voice routed (with an expression map and everything), Dorico will always throw up a Mixer channel (even when the ‘Unused’ button is not ticked). It even does this if your plugin isn’t actually using the fader, but instead routing everything to the main ‘stereo pair’.

To mix with a plugin that only uses one stereo input, you’ll typically click the MIDI tab in the mixer, and mix the individual instruments/channels from there.

Quite a few plugins just mix everything down to stereo, so all those faders but the first one are useless (I.E. Note Performer) and in the way. I think NP’s special templates might automatically ‘hide’ the unused ones, but some plugins don’t. So you could ignore it, or in the instrument setup limit the number of audio outputs to 1.

I.E. If I had set my Sonic Instrument to mix everything through a single stereo pair I could do this (Limit ‘Number of Audio Outputs to show in Mixer’ to 1):

Click the MIDI tab in the Mixer, and end up with this scenario where all of HALion slots are routed to send audio through the first Red ‘Violin 1’ channel. To do my ‘mix’ I would use the MIDI faders (The ones with no Insert slots starting just to the right of Dorico Beep 1. They will send CC7 for volume, and CC10 to pan to the plugin for internal mixing).

If you really want to force something to show up on the Mixer, even if the Unused icon isn’t ticked, then make a player/section/stave for it somewhere in the score and connect it. There are ways to hide unused staves in the various work tabs (Write/Engrave). Personally I’ve yet to find a need to do this, since we can limit the number of faders that pop up in the instrument settings and avoid getting too much junk on the mixer, but it is one way if you ever NEED it.

Thanks @Brian_Roland !
I am not at state yet, where I would use isolated effects but your description is helpful for understanding the mixing more and more. I already tried to play with some of the orchestral sounds :slight_smile:
(but I should invest the time into piano practice).