Undesired hardware MIDI controller behaviour in cubase

I’m using a Nektar Impact GX49.
No faders, no pads or knobs.
Simply connected via USB and it automatically appears in Cubase.

Now Cubase seems to think it’s a mackie device (I always have those ugly white lines to the left of seemingly random tracks).
It keeps selecting other tracks whenever i want to add a new instrument etc.
Sometimes it even toggles between multiple before it stops, and sometimes cubase even freezes in the process.

How can i get rid of all this bullshit and just use this simple keyboard for what it was meant to do? Simply play keys and use the modwheel?

I must have googled for hours and tried every solution to every midi controller problem there is, but nothing works.

Perhaps your having this issue too

[quote=“Fugdup, post:1, topic:894924”]
How can i get rid of all this bullshit and just use this simple keyboard[/quote]

Remove Nektar’s integration by either setting its ports to none or completely delete it.

Nektar’s integration, be it MCU or whatever else, is a plus which you can obviously override though this doesn’t make it less useful to others.

1 Like

I already did uninstall the nektar integration, but so far nothing changed. What else do i have to do? I’ve tried setting every ports to none but it doesnt change anything.

Here’s some screenshots if it’s any help.

Looks like you didn’t delete it from your Cubase Remote Devices.

Once you do that, it should hopefully become a regular MIDI device again.

I did, it’s gone only until i add another track or restart the project, then its immediately back in there automatically. Also tried trashing preferences or finding traces of it in the cubase folder but no luck.

If your Nektar Impact GX49 MIDI controller is causing unwanted track selection and freezing issues in Cubase, try adjusting the MIDI settings in the “Device Setup” and “MIDI Port Setup” menus to ensure proper recognition. Disable unnecessary features like Mackie Control if not in use, and reset Cubase preferences by deleting the preferences folder. Check for firmware/driver updates on the Nektar website and consider reaching out to Nektar support for specific guidance. If the problem persists, manually set up the GX49 as a generic MIDI keyboard in Cubase, or seek assistance on Cubase forums for more tailored solutions.

I’ve tried adjusting all the midi settings in device setup and midi port setup, but it makes no difference. There are no mackie control features enabled. I’ve already tried resetting the preferences. Firmware/driver updates are the latest.
I would love to try to set it up as a generic midi keyboard in cubase, but the keyboard is already automatically added regardless, so that won’t really work :\

After doing a fresh install and some registry cleanup i finally managed to get rid of the integration files. It now seems to work as intended!
Thanks for all your suggestions.

Glad you got it going.

I just got back to my DAW computer to let you know where to find the Remote Device .dll files that I had mentioned you need to get rid of. Those are not in the regular Cubase folder hierarchy, but in a more common Windows folder:

C:\Program Files\Common Files\Steinberg\Shared Components

With everything you did, I assume the dll for your Nektar Impact is now already gone from that folder.

But that’s the place to look for hardware custom dll’s that show up in Cubase/Nuendo in the Remote Devices section of the Studio setup.