Undo drops out of record

22/5/2012 - Bug confirmed and logged by Marcus. Thanks!


This is the definitive steps to reproduce the bug (taken from post 8)

DEFINITIVE STEPS

  1. Make sure “enable record on selected midi track” is enabled in Preferences (Editing / Project & Mixer]

  2. Create 2 midi tracks.

  3. Select track 1 and record midi data.

  4. Open the clip in the key editor.

  5. Select track 2 and record midi data. (nb - on record stop, the key editor swtches to the newly recorded track automatically).

  6. UNDO.

The newly recorded part is removed - AND the midi track disarmed, which is two levels of undo, not one, and therefore appears to be a bug. Behaviour is expected if the key editor stays on the same midi track - it needs to switch tracks to invoke the bug.


Below is the original OP, which contains some innacuracies in reproducing the bug

ORIGINAL POST

Here’s one that annoys me every time.

  1. Select a new midi track, record a part, screw it up, stop, press undo.
  2. The track drops out of record, but it is still highlighted.
  3. Arm it again, record a part, screw it up, stop, press undo.
  4. The track now stays in record.

Expected behaviour is that stage 2 would not drop out of record. It only happens the first time you record on the track - after then, it stays in record.

Can others confirm for a formal bug report? Am on Cubase 6.0.5, Win 7 64 bit.

Redacted

I love this forum, everyone’s always ready with a friendly welcome…

It deviates from how it is supposed to work. Pretty simple really:

STEP 1 - select track. Arms automatically.

STEP 2 - record midi.

STEP 3 - undo.

Undo should go back 1 step - in this case STEP 2, the recorded midi. In fact, it goes back 1 and a half steps on the first go round to the middle of STEP 1. From the 2nd go onwards, it behaves normally.

If this is reproducable across the board, it is deviating from expected behaviour by going back more than one step. Ergo, a bug.

Not reproducable here all works as expected.

Hippo

Matbe the OP needs a quick study of the Preferences and a quick peruse of the transport bar settings.

I have found many things that I thought Cubase should do only later to find that I’ve missed some setup detail. It can be infuriatingly complex to set up.

Thanks Hippo - what’s your version and OS?

Conman - what preference might affect undo on a first pass, but not subsequent ones?

I’m not sure. I’ll have a look later and see if I can remember. Should be under Record / Audio or something.
Could be to do with stacking takes.
Look up “Track arming bug” in the forum. I think it got fixed with a Preference a while ago.

I’m pretty sure you shouldn’t be getting this though. You could also try the old “trash preferences folder” solution if it gets too much.

Thanks Conman. The only preference that seems vaguely relevant is “enable record on selected midi track”, which is enabled.

I did some reading on the track arming bug - that looks different to me, I’m not getting arming on random tracks, just an incorrect disarming on UNDO.

OK, I’ve done some more tests, as in some conditions I wasn’t getting the bug. I’ve discovered that the issue seems to arise when the key editor is open on track A, then you record a new midi part on track B. I’ve updated the reproducible steps:

  1. Make sure “enable record on selected midi track” is enabled in Preferences (Editing / Project & Mixer]

  2. Create 2 midi tracks.

  3. Select track 1 and record midi data.

  4. Open the clip in the key editor.

  5. Select track 2 and record midi data. (nb - on record stop, the key editor swtches to the newly recorded track automatically).

  6. UNDO.

The newly recorded part is removed - AND the midi track disarmed.

So there was an error in my original OP. It’s not a 2nd arming that cures the problem - the problem is instigated with the key editor is open on one track, and a new part recorded on another.

A rare thing. Me saying that actually looks more like it could be a bug.
I don’t know how many people work that way although it’s a logical way to work so more people could find this happening.
Good digging I wish more users would go a little deeper into their problems sometimes.

Thanks Conman - do I just wait for someone from admin to notice the thread?

If it gets in the way too much maybe drop a line to support (giving this link) and see if it gets flagged.
Maybe “bump” the thread for a week or two.
Hard to see if it’ll get noticed as they may see it as a minor bug compared to something else unless it’s linked to something bigger.

Thanks Conman.

Mods - did you remove my last bumps? Is so - why not acknowledge the issue?

Bump for mods acknowledgement - this is a reproducible bug.

Another bump for mod’s acknowledgement - thanks.

…and another bump for mods…

…and another…

…and another…

Did you actually put in a support ticket to Steinberg support through MySteinberg? Might be more effective and less annoying…

I thought the thread here- http://www.steinberg.net/forum/viewtopic.php?f=19&t=3400 - said that this was the correct method? But fair enough, if that method is the way to go I’ll try it- thanks.

No, you’re right. I just didn’t realize you were aiming to get this into the ‘bugbase’ topic. You might want to add “BUG?” in the title of this thread. And hey: this is another free bump from me! :sunglasses: