Unexpected behaviour"move to staff below" and "tuplets"

I just tried some voice splitting things, and I found the following behaviour.

If you move the “flute 1” notes down to the “flute 3”, the second quarter note jumps one eight.
Bildschirmfoto 2023-07-27 um 18.33.29

I know there are some strange behaviour with tuplets and move notes “through” staffs, but most of the time, you can solve it with insert mode and delete the new tuplets. But here it is quite odd.

Interesting. I tried this myself. To reproduce a minimal case:

  • Enter the rhythm shown in Flute 2 above
  • Select only the quarter notes on either side of the triplet
  • Alt-M to move them down a staff, or copy to anywhere with Alt-click

Expected: Two quarter notes on beats 1 and 3 (as in Flute 1 above)
Actual: as above in Flute 3

Clearly the triplet is being accounted for in one way, but ignored in another.

Workaround: Include the tuplet (without the notes) in the selection. You get a tuplet of rests you can delete … which might be slightly easier to filter than copying all the notes and deleting whole tuplet(s) afterward.

Interesting. It works OK if Flute2 is not in upstem voice1.

If you have a note on beat 2 of flute 1, it will “drag” the tuplet to the flute 3. you can clean this up easily. With a rest, this doesn’t happen.

Makes sense, it works, if flute 2 is in another voice.