Unexpected host behaviour while importing AAF

When i want to import an AAF file (i do have the AVID plugin) i keep getting the message
Unexpected Host Behaviour. and the file is NOT imported…

what to do???

Is it Cubase you’re attempting to import the AAF file into, and if so, what version of Cubase, and what application (and version of it) generated the AAF file?

Or are you trying to import an AAF file generated by Cubase into another application?

What does the AVID plugin have to do with this? (Cubase can import AAF and doesn’t need any additional plugin).

Hello MrSoundman,
I am indeed attempting to import the AAF file. My cubaseversion is 12-pro. I’ve made the AAF in davnci resolve.
Thank you for letting me know that the AVID plugin is not needed.

i think i try to make an other AAF… and try again…

FWIW, C12 imports AAFs from Vegas OK, but reports vary from other applications. Over in the Nuendo section of the forum there are likely to be people who import AAFs from Resolve, if you want to ask there too.

Nuendo user here -

Resolve is known to be generally terrible with AAFs unlike other NLEs like Media Composer or Premiere Pro.

You need to go to the Resolve deliver tab, and click the “PRO TOOLS AAF” option at the top (or called something similar) , even though its going to Nuendo. I’ve found it’s much more likely to work if you export a non-embedded AAF as opposed to embedded AAF.

Let me know if you can’t get it to work and I can hop on my computer and send you a quick tutorial video which I send to any editor I work with using Resolve.

ps - I don’t use Cubase, but I’m assuming import should be no different than Nuendo?

1 Like

Just to clarify, this is what you want to do in Resolve to successfully export an AAF that works in Cubendo:

  1. Go to the “Deliver” page
  2. At the top, scroll over until you see “Pro Tools” - select that
  3. Below, deselect “Export Video”
  4. Click the Audio tab
  5. Make the format “Linear PCM” - NOT “embedded audio”
  6. Add to render queue and export to a folder on your drive.

This should successfully import into Cubendo

ps- Resolve’s timelines generally start at 01:00:00:00, so when you import into Cubendo, you’ll probably need to scroll over to the 1 hour mark to see the audio

1 Like

Dear Nogills,
thank you for your tips. I will try your way and i think it will work out.
I only have to tell my client to render the film alswell

thanx to you all, i will keep you posted!

YEA it worked! thanx