Uninstalled HALion 6 then tried to reinstall, and installer disappears!

This sound familiar to anyone else?

Actually the problem is even quite a bit bigger than that: I am trying to reinstall HALion 6 because I was having no success in getting HALion Sonic 3 to load (or even be recognized in eLicenser (even though I have a full license)). After trying this several times with no success, I finally decided I’d try uninstalling Sonic 3 and then reinstalling it. But when I tried to reinstall, the installer progress field gets to about 1/4 in and then the box just disappears!

After going through this far more times than I can count, and after equally countless conversations and chats with Yamaha/Steinberg techs-all to no avail-I decided that since I got HALion Sonic 3 along with HAlion 6 in the same installer, I should try to uninstalling HALion 6 and then re-receiving HALion Sonic 3.

Then right after attempting the HALion 6 reinstall, the installer started doing the same thing that it was doing when I tried to install Sonic 3.

I am at my wits end: I have updated my BIOS, my entire system (Win 10 Home, Version: 21H1 OS build: 19043.1052) bought an entirely new dongle and transferred all my licenses to it, updated my Nvidia Graphics Driver-all of this at the eager suggestions of multiple techs, but NONE of it has worked. The next thing they actually suggested was that I re-install my system, continuing along this thread of thought that the problem MUST be something unrelated to the HALion 6 update-even though before I updated to 6 everything with all products Steinberg on my system was completely fine up to the point where I installed HALion 6. So, I’m not happy.

Is there anyone out there with any similar experiences? If so, please tell me what you did to fix it?

Thanks for reading.

Clay

From your involved message I don’t really understand what you need.

When you say the installer disappeared, do you mean it quit unexpectedly, or the installer exe itself somehow disappeared?

Are you using the Steinberg Download Assistant or are you downloading from the website?

I mean the actual installer dialogue box will show up as usual, and the green progress field near the bottom will show up. And then, right around where the progress bar gets about a quarter of the way in, the entire dialogue box just disappears.

And this happens whether I try it from the Download Assistant, or else attempting to open directly from the install exes that have been downloaded (the same files that the Download Assistant goes to to start the installation process.)

I have not attempted to do this from the website.

this is what I’m talking about. Was able to get off on screen capture, just before it disappeared.

This probably indicates something wrong in your Windows installation.

Have you already eliminated the possibility of corrupt system files?

See Use the System File Checker tool to repair missing or corrupted system files

Hmm-interesting that you are thinking it’s a System Installation issue. Would you mind fleshing out to me the reasons why you’re thinking System? I’m not meaning to sound contentious: though I am dreading it, I will say at this point as long as it seems very likely that a Resetting my PC is the only solution, then I’ll do it. I’m just confused on why it would seem like a corrupted system issue when A.) just last night I did a full Windows update (the three hour kind), and the problem still persists exactly as before and B.) I didn’t have any of these types of problems before I updated to HALion 6, and I was using this same system the whole time.

I will check that link you sent, in the meanwhile-Thank you very much.

And, as a direct answer to your question: no, I had not eliminated the possibility of a corrupt system file through the use of this utility that you have just revealed to me. It looks powerful and I am definitely willing to try it first.

The main reason people are advised to reinstall Windows is because the expert thinks the user will not be able troubleshoot.

Just saw your latest post. Great. Do the DISM tool, and then follow through with the other steps if needed. Post back your result.

Ok-I’ll start now. Thanks for bringing it to my attention. I’ll keep the thread posted.

Ok-Steve, “the restore operation completed successfully”. Does that mean no errors were found? Should I try to install HALion 6 yet?

Just tried a reinstall. No changes. I haven’t tried a Restart and then reinstall yet. I wanted to hear what you thought.

You didn’t do the next part from that page.

I can only help you as far as you permit, and I’m not being paid to do it.

If you have your files properly backed up, reformatting and OS reinstall might be the easiest thing to do.

I misunderstood the page: I thought that the DISM was all there was to it. I’ll read on and do the rest. Keep you posted.

I just initiated a scannow. It was not written in a really clear way that they wanted this done after the DISM part.

Well, if you don’t read to the end…

Computers work great till they don’t and if the user did not already research how to maintain the computer and software, and to have a reliable backup strategy, disaster is inevitable. What you’re seeing is a micro version.

If scannow doesn’t find anything to fix, you should revert to a previous restore point, or use Windows Update to uninstall the big update you did.

Then research the main problem you’re having, which is the Windows Installer executable quitting unexpectedly.

Also: see Recovery options in Windows.

It says it did find corrupt files and repaired them, but then I attempted to reinstall HALion 6, and there was no change.

I’m not sure why I’d revert the big update I did because I updated from a system that was doing exactly the same thing as what’s happening now-with HALion 6/HALion Sonic 3. Not with HALion 5/HALion Sonic 2.

And I will research the executable quitting as you have suggested.

Of course you then restarted the computer., right?

Are you asking me if I restarted right after scannow? If that’s what you’re asking then no I didn’t. I had not yet gotten an answer-from you or the Microsoft page-that that was needed.

So I will try that now-thank you.

What’s possible is there’s a registry error causing this.