Unmapped ports and other similar problems

Firstly, some setup information:
I have recently bought a UR22mkII sound card for my home studio. I got a microphone connected to Input 1 on the sound card. I got headphones connected to the “phones” jack. My sound card is connected via USB to my computer. I am able to use both microphone and headphones on my PC via my sound card.
I got a stationary computer with good specs, so that shouldn’t be a problem.
I am new to working with both recording and DAWs, so if you could, please explain thoroughly in your answers.

Problems I have:
Under studio > Audio Connections > Inputs, I can’t find any inputs, doesn’t seem like “Cubase LE AI Elements 10” finds/recognizes my recording equipment. In Studio Setup > Remote Devices, I am able to select Steinberg UR22mkII for MIDI input and output, but that’s the only place i can find my sound card at all. Under VST Audio System, the ASIO driver is set to Generic Low Latency ASIO Driver (Not sure if that’s relevant information because I’m not exactly sure what it is, but added just in case).
If I try to start a new project, a window pops up, “Missing Ports”, where it says both microphone and speakers are unmapped. I am able to select “Realtek Digital Output” for Speakers (I don’t even know if that’s the right option because I’ve got a Sennheiser headset, connected to the sound card. It is the only option apart from “Not connected”). However, I am unable to choose anything else than “Not connected” on Microphone.

If I continue, with unmapped ports (“Not Connected” option selected), I get a project file, with some tracks (the one I chose). In this case, piano and vocals. In the Inspection section on the Vocals track, I am able to select Mono In 1 in the Input Routing, which should be the line my mic is connected in. In Output Routing I am able to select stereo out, links or rechts under stereo out, or no bus; but nothing I recognize (like I recognized “Mono in 1” selection).
On the piano track however, I am able to select Steinberg “UR22mkII -1” in the Input Routing. In the Output Routing I can select different VST instruments. I can try to record, but only the vocals get something (Audio wave thing - except there’s no wave or anything that plays back to me when I try to play it). The piano track doesn’t get any selectable/editable audio wave thing at all.

I want to use Cubase to record, edit and produce songs.

Any answers/responds are appreciated. Thanks.

Hi and welcome,

In Studio > Studio Setup > VST Audio System, choose Yamaha/Steinberg ASIO driver. Then you will see UR22 as an Audio Input device.

I would recommend to follow some Quick Start Video Tutorials on the official Steinberg’s YouTube channel.

I would do that as well because guy in Quick Start Video said so, but Generic Low Latency ASIO Driver is the only option I have. No other options appear, except “No Driver”.


Make sure, you have the driver and the Tools installed. You can download the latest version here.

Thanks for answer. I haven’t been able to download the “TOOLS FOR UR22mkII” because I don’t have a CD/disk-player in my computer, but I’ll probably be able to acquire a portable one which I can download. I have the Yamaha Steinberg driver, though.

I assumed that disk was extras, and wasn’t so crucial. I will download that and try again. Thanks for all the help, sorry for occupying time and space on the forum without even having downloaded that.