Unplugging headphones changes khz

Hi, I’ve been running into an issue on my macbook pro where the entire mac’s output is set to 48kHz in Audio MIDI setup, however if I’m using headphones and unplug them Cubase will switch to 44.1kHz. It then gets stuck at 44.1k until I switch audio drivers and switch back. Replugging the headphones in/creating a new project doesn’t fix it until I switch the ASIO driver and switch it back again.

I’m not sure why it switches to 44.1kHz at all, since when unplugged it goes to built-in-output which is set to be at 48kHz as well.

I’m using an aggregate device I created for the headphone output since the normal external headphones option does not show up in Cubase under possible outputs.

Thanks.

Hi,

Is the Aggregate Device set to 48kHz, please?

Hi, yes it is but after some more testing it appears this is a mac issue. Unplugging headphones changes the kHz in audio midi setup for built-in-output from 48kHz to 44.1kHz