Unstable CPU on 10.5 with Samsung TV 4k and MacMini 2018

This is the differences between 10.0.50 and 10.5 with the same project with opened mixer

10.5 needs more CPU power and its so unstable

Macmini 2018 i7, 32gb ram , latest Mojave

EDIT: well… ofter few days of researching for my problem , i found and isolate the issue . The problem is the graphic from macmini 2018 and my TV Samsung 4k … Only with Cubase 10.5 when i start play cpu goes high … when i open the mixer … its worst … everything going in red and cant play anymore …

when I significantly reduce the window size of cubase and mixer too, cpu back to normal … also ,with asus full hd monitor , works perfectly … My friend has 4k monitor and the same macmini2018 and he has no problem with CPU … so i can conclude that my problem is TV … Samsung TV 4k and Cubase 10.5 will not work together… Can you believe that ?

Something is not right… frame rate has dropped so the mixer feels useless even on light loads without any load on the cpus.

Are You using any uad accelerator? ( I can see some uad plugins) Thing is that outdated driver or firmware for theese HW could be rootcause. Problem is that this performance meter showing overal response of all HW, SW tasks and firmware tasks to work in realtime. In my case(win10) I have sometimes overload on this meter but audio is not afected, otherwise, sometimes was afected without any notice on this meter. But this is another story.
Try some project which using minimum of external HW. check some videos how to properly set up PC for low latency, realtime performance
https://youtu.be/GUsLLEkswzE
Try to update every firmware, driver etc. and You should be OK.

all updated. CPU is 20% higher on 10.5 for some reason

Are You using any of steinberg hardware? If yes, check current compatibility here: https://helpcenter.steinberg.de/hc/en-us/articles/360010461459-Cubase-10-5-Steinberg-hardware-compatibility

By that chart both my CC121 and UR28M are not compatible with C10.5 yet?
Seriously?

Anyone here with macmini 2018 ?

Have you tried saving the 10.0.50 project as a new file (or version) in 10.5 and then closing and opening it again?

I remember someone mentioning this solved their similar issue updating from a .0 to .5 release

I didn’t watch the performance meter on my projects, but I did some exporting tests and I got the exactly 20% slower on 10.5 Which makes perfect sense if it is 20% higher on CPU.

Something is not right.

When first opening an existing C10 project with C10.5 I had a similar giant spike in CPU use - like, CPU use bouncing between 90% and 100% to the point that the whole system was barely usable. This is a very small project, with just a handful of audio tracks, never took over 10% CPU on C10.

I started removing plugins to see if that was the problem, and sure enough: removing Valhalla Delay, in this case, fixed everything and the CPU use went back to where it was with C10, if not lower. Replaced Valhalla with the new Multitap Delay (which is oh so good btw), then continued to work well into the night and had no issues at all - buttery smooth.

So… looks like there might be a change in the VST runtime that is killing some plugins that had no issue with version 10. In my case the only one having a problem was Valhalla Delay (I tried other Valhalla products just to see, and they were not affected and worked fine), but I am guessing there might be others.

Anyhow… not sure this is the only issue, but it was it for me.

The project I’ve been working on actually loads up with slightly less cpu in 10.5 than 10.0.50.

I had CPU spikes and high ASIO usage but after switching “Processing Precision” from 32 bit float to 64 the spikes went away and ASIO usage dropped around 15%.

Cheers.

Same here, very loud CPU in 10.5 then 10.0.40. Valhalla modulator?

I don’t have any Valhalla product in the projects . I try everything but … 10.5 is so CPU unstable in my case.

I don’t know what to do . Any words from Steinberg? Some help?

Try disabling “suspend VST3 plugin processing” in preferences and also set asio guard to high. It worked for me. I don’t know why it happened in the first place, but I noticed this weird “cpu to max” behavior in 10.0.40 also. I have a feeling that it is some kind of third party vst3 plugin that causes this.

This is from my friend who also have MacMini 2018 … same project, same settings …


Thanks for all the reports guys. I’ll hold off on 10.5 for now, until anyone can address why is this the so.

Do you have Asio Guard on or off?

CPU immediately hit the roof for me with 10.0.50 and then 10.5 so there;s some change under the hood from 10.0.50 Build that affected my system - even on an empty project.

I have not being using Asio Guard so I was clicking around trying things. When I turned ON Asio Guard the CPU load went back to normal ( 4 or 5 % on empty project )

already have disabled that … I try everything , no help …