Unusual behavior when saving existing file

The specs: Dorico on an iMac running Catalina 10.15.7 with the latest security updates.
I recently installed Dorico on an iMac as my MBPro where Dorico has lived since version 1 is in the shop for repair. I already own the Steinberg eLicenser and decided to use the dongle in order to use Dorico on both machines.

Here is the scenario on the fresh install on the iMac: I open an existing file either from the hub or from the File Open dialog. When I go to save after making a change, I am prompted with the Save As dialog instead of automatically saving it to the original location. I don’t see anything in the preferences or anywhere else that addresses this issue. I don’t recall this occurring on my other computer. Is this a bug, or I am I overlooking an obvious setting. It is quite annoying.

Thank you in advance,

Morristown, NJ, USA

Has Dorico crashed/hung recently? If so, you’re probably opening the autosaved version of the file that Dorico recovered after the crash. You should save in a normal location (your documents folder, or Dropbox or whatever) and ensure that when you launch a project you’re launching the correct version.

If Dorico hasn’t recently crashed, and you haven’t inadvertently been trying to save to the AutoSave folder, is there anything odd about your save location? Cloud storage, perhaps?

No crashes, Leo. It is a fresh install. I have the path displaying in the hub and it opens the correct file location. This happens with every file I have tried it with. Even files I open directly from the file location in the File Open dialog. Very strange.

My storage is BoxSync which I have used since Dorico 1 without a problem. You’re probably in the the right problem area. I’ll have to investigate more.

I seem to recall that when launching programs on Big Sur for the first time (possibly Catalina too) I was asked to give each program permission to access certain locations. It might be that you need to give BoxSync that permission as well as Dorico; I’m not sure.

I solved it, Leo. When I installed Dorico on this new machine last week, I set the Backup folder to the same location as the root folder, i.e. /Users/MyName/BoxSync/Dorico. Changing the Backup folder to /Users/MyName/BoxSync/Dorico/Backup solved the problem.

Thanks for reading my topic.


1 Like