Unusual pitch change issue

I have a problem that I haven’t been able to find a solution to in the forums; there are somewhat similar issues, but nothing exact. Randomly, pitch will change in either or both input and playback by varying degrees - either a quarter step or half step. Sometimes on playback if I simply play it again it fixes itself and on input, if I click onto another part it usually fixes it (not always)Also, on playback, it sometimes only changes one part by a quarter tone so it just sounds like the ensemble is playing hideously out of tune.
I am running Dorico 4.0.10.1044 on a Mac running Monterrey 12.4 through a Scarlett 2/2 interface. My midi input device is an M-Audio Hammer 88 . No other program is running, and I have reset the sample rate (44100). It seems as if the sample rate is changing randomly, although I don’t see how that could happen. I’m not sure if it’s a Dorico or a Mac issue, but it is becoming very problematic and I could really use some help fixing this! Thanks.

Just in case it’s the keyboard that’s the problem, have you tried disconnecting the keyboard, closing and reopening the project (or Dorico) and initiating playback again?

(Also, Dorico 4.1.0 came out last week - it’s a free update.)

It does sound like a problem with the keyboard’s pitch bend wheel, similar to this earlier thread:

1 Like

Hello, @David_Campo … as @dspreadbury mentioned I had the same issue and it is indeed related to my M-Audio Keystation 49 MK 3 Controller and not related to Dorico in any matter. In my case, the issue disappeared when unplugging the controller. Also, I noticed the green midi signal of Dorico being activated without me playing the keyboard which means a midi signal has been sent to the software. Apparently, the poor quality of M-Audio products has been paying off lately. I read in other forums not related to Dorico that the way my specific controller is built has played a role in that malfunction. To turn off the undesired “effect” I have to activate the pitch bend manually when it occurs (either playback or entering notes) it is annoying in terms of the pitch but in the meantime, it is a partial solution.

@jguerramusic try these….

Please check this post! I have an axiom pro and I have a lot of troubles From one day to the next it was working fine and then suddenly nothing, it was sending me constant midi messages according to the green light showing midi activity in dorico.

When I activated this option mentioned by daniel in the post everything was solved.

1 Like

How do I get to the page that I’m looking at? Where is the “Filter out MIDI controllers” located?

Sorry if that’s a dumb question…

David

Dr. David W. Campo
Professor Emeritus of Music
Stephen F. Austin State University

It’s under Preferences/Play.

1 Like

After trying all of the recommended steps, I still had the issue with random pitch changes. It became clear that this wasn’t a Dorico issue, but something else. I started by changing out my input device and the problem was instantly resolved. I did some research and discovered that M-Audio keyboards tend to develop issues with their pitch wheels that cause them to send faulty midi data and it’s apparently ubiquitous; it’s not just the Hammer 88 I was using but all M-Audio products. So, thanks for all your help and a heads up to anyone who has M-Audio products.