Unwanted accidentals in diminished octaves

I cannot find a setting in Notation Options that prevents Dorico from repeating the accidentals in the red rectangles.

Am I missing something or is this a limitation of Dorico?


I believe you’re right, short of disabling cautionary accidentals, which I guess you don’t want to do. It’s difficult to see how to avoid them in general, given that on the whole these intervals do benefit from cautionary accidentals.

Even disabling every possible cautionary accidentals in Notation Options does not avoid these accidentals. As far as I can see the only way to get rid of them is to hide them manually with the setting in Properties panel.