unwanted controller data is transmitting to VE Pro ....

I have the master volume getting turned off in instruments loaded into Kontakt due to unwanted controller data coming from Cubase 7.5. When I stop the playback, volume goes to zero in several Kontakt instruments loaded in VE Pro. I’m using the vst3 version of VE Pro 5 in Cubase.

Is there a way to prevent this? When I turn off Chase Controller in preferences the problem stops. But I want to keep the ability to chase controller data! I have discovered I might be able to add a script to Kontakt 5 that filters out some controller data, but I’d really like to prevent unwanted controller data from flying around.

Anyone know how to do that? I’ll try the filters, but I’m not sure that will catch it.

Thanks,
Paul

I’ve got it mostly solved. I can’t seem to find a way to keep Cubase from sending out the standard master vol and pan messages, even sending them from buttons on my Frontier Tranzport controller, but in Kontakt, you can go into edit mode of the instrument, into instrument options, the controller tab, and turn off the standard master vol and pan there. It stops the volumes of a BUNCH of instruments in my template from jumping to zero.

Paul

Are you inserting VEP as a track or a rack instrument in C7.5?
I dunno if that makes a difference, I’m just throwing it out there.

Also have you tried using the VST2 version? I’ve been using that and don’t have the problems you describe, but I’m also not sure what advantage the VST3 has except a better sidechain option in the mixer, which I don’t use since I do all the mixing inside VEP anyways.

If none of that helps, if you have an example metaframe and cubase project (or just tell me how you have it set up), I could take a look.

I have VEP inserted in the rack. I haven’t tried the VST2 version, but that was going to be my next step if I needed to take it. I still may check it out. In vst3 I can get 48 instances/midi ports. Is it that much in vst 2 ? If I understand correctly, you have to use VEP Event Inputs to get more Ports per viframe instance, correct? And that add a buffer I believe.

I’ve got the current problem solved… until I need to use cc7 or pan to respond to automation in VEP Kontakt instances! Normally I rely on cc11 expression and any panning tricks/automation I save for the audio track mixdown step anyway. I’m setting up my first template in VEP Pro in the DAW then have three slaves to do, too. If my understanding of vst 2 vs vst 3 VEP’s is correct, I’m more than willing to sacrifice the cc7 and pan in Kontakt.

Thanks for the response,
Paul

I’ve just inserted multiple instances of the x64 VST2 plug-in, one for each metaframe instance on the server, and they each seem to handle multiple ports and all that pretty well.

I’ve got 11 MIDI ports and 112 audio outputs per instance, and it’s going strong! No odd, unaccounted-for CCs floating around with PLAY or Kontakt. Here’s one of them:
NEVERMIND, I see what you mean. VST2 only supports 1 port per instance, even if the metaframe supports a bunch.


I’m more concerned about where the phantom CCs are coming from in your case. That shouldn’t be happening to just the VST3 version, so it’d be weird if it was exclusive to that.

Do you have a small / non-important project file you could upload that has the problem going on? If it’s exclusive to you, it might be a specific pref or some other weird thing.

I’d love to discover the actual source of the issue. PM me and I’ll email the project I’ve made for creating the template.

Thanks,
Paul

Dropped a ping, check your inbox whenever you get a chance.

Ha, I’ve been messing with other things and then went back to check the issue again, and it won’t do it! No idea why, but I still don’t trust it. I have now set all Kontakt instruments to nominal volume and installed mult-script blocking master vol and pan. I won’t then need to automate cc7 since cc11 expression is all I ever need, especially with all vol set to nominal.

Thanks,
Paul