unwanted echo

I’m working on my first cubase project.
I’m having a problem with entering material using my MIDI keyboard.
When I play the keyboard in this project there is an echo effect. It happens with each of the tracks I have added but doesn’t happen when adding material manually in the key editor or if I open a new document.
Is there a setting I might have accidently changed my project to? If so, how do I get it back to normal?

Is it an echo or a delay?
An echo could be caused by your controller sending two notes for each key press. This happens if you enable, for example, a MIDI in port and a USB in port. (or you may have a USB A and USB B ports)
If it is a delay, check the buffer latency.

…or you might have a midi-loop. You do have to set your keyboard to “local off” in order to prevent that (or alternatively disable midi thru in the cubase references).

Cheers, Ernst

Thanks. It is definately an echo not a delay. And it doesn’t happen when I’m selecting a new instrument, only when the track has been created.
I don’t fully understand your answers. How can I set my keyboard to “local off”?

Just to clarify, does your keyboard have its own set of sounds that you monitor through a different set of speakers from that of your recording setup, or is it just a keyboard controller with no sounds of its own?

+1 for ‘local off’…

have a look at the manual for your keyboard… check the index/glossary for ‘local control’…
If this IS the problem then what’s happening is that not only is your keyboard sending midi information to itself via its keyboard but the information is being sent too and then back from your DAW… think about it for a few minutes :wink:
This will cause each midi event to be triggered twice… it will sound like an echo because of the round trip delay of the signal being sent to and from your machine…

of course it could be something else entirely but it does sound very much like your problem…


My keyboard doesn’t have any sound of its own.

I don’t have the manual on me at the moment. Will have to check it for “local control” when I get home.
Also, not sure if it’s important but the echo doesn’t happen in playback after I’ve recorded something, only when I’m playing the keyboard in a selected track.

If your keyboard doesn’t make any sounds of its own it will not have local control, don’t bother searching :slight_smile:
In that case it sounds more like a midi routing issue, as the soundsource is somehow receiving every midinote twice.


well, so local off is not the point.

Please have a look under “devices” in the cubase menu and there at the midi ports. Tick on the “use system timestamp” option for every port type. Then look whether single phsyical ports show up twice in the list and deactive the double entries if they exist.

Regards, Ernst