Unwanted rests in drumset

Hi, I do not manage to get rid of the rest in the following exemple:
Unwanted rest.PNG
I do know how to do this in other instruments with multiple voices but here, in unpitched percussion, the rests don’t go away with “remove rests”, or “starts voice/ends voice”.

Unfortunately at the moment there’s no way to remove unwanted rests on unpitched percussion instruments when using either the five-line staff or grid presentation types.

OK, Daniel, but is there any reason not being able to “hide” elements in the score, just visual?

Could be a text consisting of a couple of spaces with white background and foreground placed over this rest in engrave mode be a workaround?

I’m afraid you will have to wait for an update on the unpitched percussion notation. Those rests are not “objects” you can manipulate, they are a creation of the software when it performs the “reduction” on a staff or a grid of the different instruments involved. By now we have no tools to interact with them, we need the devs to create those — or other ways to deal with the result of such “reductions”. I don’t think I’m wrong when I think we shall be patient.

I understand the principle of rests as part of a “grid”. You cannot have “nothing” in a voice. So you have to end and start the voice in order to remove the rests.
Still being curious why there cannot be a visual “hide” of whichever selectable element.

If the “D and A” are toms and the “F” bass drum, you could use voice 1 and voice 2 for the 2 instruments, eliminating the rest.

You can only change the voicing of unpitched percussion for single instruments in Setup “Edit Percussion Kit”. This changes the stem direction and voice for the whole instrument. You can give everything the same stem direction and voice, thus eliminating the unwanted rests indeed but then you get unwanted ties instead!
The last question in my previous post remains but maybe it’s a different subject…

I think I read an explanation from Daniel somewhere stating that percussion staves are proxies for individual instrument staves. If I remember correctly, they mirror the explicit objects (notes, dynamics etc.) from the original staves, and fill in the gaps automatically with implicit rests. The percussion staves don’t store any information locally so there’s nowhere for show/hide information to be saved.

Daniel will likely be along to explain, and I’ve probably messed up somewhere in this (mis)remembered explanation.

(laugh), well, anyway, thanks!

I am having a similar problem with a basic drum set. I have watched the videos that never seem to have this situation. But I cannot get around it.

See Perc Extra Rests.JPG. I get along fine with snare and bass, but in measure 9, after I to the crash symbol. that voice is adding rests in every following measure. I can’t get rid of them. I tried setting that crash as the end of the voice. I tried the notation option “Do not pad voice with rests”, and several other things. I had been making some voice changes manually, mainly because I find the whole voice thing completely disorienting. I can never tell what voice I am in.

I deleted the entire player and started from scratch with “Use voicing defined in kit editor” but the problem persists.

A similar problem appears at bar 29 with unwanted rests before and after the ride cymbal. See Ride rests.jpg.

What am I doing wrong? This cannot possibly be right.
Ride rests.JPG

Craig,

I’m a total novice when it comes to percussion in Dorico, but I thought I’d retype your problem bars and try to figure it out.

Here’s my result:

Through to letter B (my letter B, not yours) I didn’t touch voices at all. I just played in pitches on a MIDI keyboard, with the F, C and A above middle C (imagine you’re in treble clef). Dorico knew to give the crash cymbal an upstem and automatically put the snare and kick on a downstem. At B I played in the ride cymbal. I then selected the note, right-clicked, went to Percussion > Change Voice > Extra Up-Stem Voice.

It seems like I did exactly as you did, except I entered the notes from the PC keyboard instead of the MIDI keyboard. I did not use voices at all. I see in the percussion kit, it has everything assigned to voice 1.

I created a whole new Dorico file and added a player with the basic drumset. I pasted in the first 10 bars and the rest problem did not appear on this new file. So evidently there is something really hosed in my Dorico file. I would have thought that by deleting the player entirely and adding a completely new players, that would clear out any residue, but I guess not.

I wonder if anybody has any best practices for rebuilding a Dorico file that has been corrupted. I’d rather not have to rebuild everything from scratch with cut and paste. I tried an XML export and import into a completely new DORICO file. The rest problem remains, and many other elements are messed up or missing, so that’s not a good option.

Craig,

I then selected the note, right-clicked, went to Percussion > Change Voice > Extra Up-Stem Voice.

Did you try this?

No. I missed that. I was looking at Voices -> Change Voice etc.

Your command works !!! But now I am more confused than ever. According to the voice colors, the crash cymbal was ALREADY on a different voice, even though in the percussion kit, everything is voice 1 by default.

And if I make the crash cymbal voice 2 in the kit, that does NOT fix the problem. It seems completely wrong that we should have to enter your command every time we use the cymbal. And why is the “percussion voice” different from other voices"? This seems really convoluted.

Anyway, thank you for that workaround. I hope that is not the final answer. But it will let me finish the project.

Percussion voices are different to regular voices because they’re not actually voices at all - they’re a representation of a multiple separate staves condensed onto a single five-line stave.

From my experiment, I don’t think you need to make the crash cymbal another voice; you just need to ensure that your crash and rise cymbals are on different voices to each other or Dorico will try to pad the gaps with rests.

I had to change almost every cymbal strike in the entire piece with the Percussion > Change Voice > Extra Up-Stem Voice.

And I am still left with some whole measure rests I can’t eliminate. See picture. I can eliminate those rests by switching to the Notation Options -> Percussion -> Use Single Voice. That means I have no control over up stem for cymbals and down stem for everything else, but it is OK for this project. That’s surely not a general solution though.

Wanted to resurrect this thread because I’m having a difficult time getting Dorico to quit padding a drum set part with rests.

Dorico 2.2.20 Mac

Attached screenshots of what it looks like, and so far the only settings I’ve changed from the default. I’ve also set snare and floor tom to go stems-up.

Any ideas?


Try this thread, last updated less than a week ago: https://www.steinberg.net/forums/viewtopic.php?f=246&t=165476&p=885328&hilit=Extra+percussion#p885328

I appreciate the reply, but it doesn’t look like that conversation would solve specifically the rest-padding problem I’m having. Unless there’s a deeper thing there that I’m missing, which there probably is.