Unworkably laggy

Michael, can you please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a look at the logs?

You can find all of the files needed in the original (top) post. Let me know if anything is missing. Many thanks!

The most recent logs are from more than 24 hours ago. Please do Help > Create Diagnostic Report again so I can look at the logs from your most recent sessions.

Oh, I didn’t realize!. Here: Dorico Diagnostics (1).zip - Google Drive

Cheers!

There’s a development: Now if I perform some operation Dorico doesn’t like, it just quits.
I had the project crash once when I was deleting a tuplet, and one minute later when I was moving from write to print to engrave too quickly.

Another time was right after I instered text with Shift+x. The text jumped all across the screen before the program crashed.

image
image

Concave_convex 2.dorico (1.4 MB)

Your diagnostics to date don’t include any crash dumps. Perhaps that’s because Dorico hasn’t crashed before, or it could be because your computer isn’t set up to produce crash dumps. Please follow the steps under Dorico is crashing. What do I do? here so that when Dorico next crashes, it will produce a crash dump. Then reproduce the crash and generate a new set of diagnostics. If the resulting zip file is too big to attach here, please send it to me via WeTransfer or a similar service to d dot spreadbury at steinberg dot de.

I’ve also been struggling with lags, hangs and crashes, so have done a lot of experiments. Haven’t loaded your project but I assume it has a bunch of stuff in it. In my very large scores Dorico starts to lag to where it becomes unusable. HALion is mostly fine, but any other library isn’t. The best solution that I’m using now (which costs some $) is to use Vienna Ensemble Pro. This offloads the VST’s to a VEP server and Dorico becomes usable again (not as zippy as a small ensemble, but usable).

If you already have a DAW like Cubase there’s another approach you can use with that.

I’m having issues even when playback is turned off completely.

Here is a new diagnostic file. I can verify it has dump files.
Diagnostic File

Not of much help, but just to put things in perspective: on my machine (a Mac Pro 2013 with 12 cores and NotePerformer) entering notes is much faster than in the video. Entering a note in an empty bar is nearly immediate; in a bar already containing notes, just a bit slower (but under half second).

(By the way: fantastic work, you are doing!)

Paolo

1 Like

I’ve also experienced the same type of lag in the OP’s video but only on occasion and I can’t figure out why. It only happens on my [more powerful] imac, never on my mac mini. Sometimes Dorico is so slow in processing the input from my midi keyboard that it will turn a whole passage into a chord even though chord mode is not turned on. The only thing that has ever helped is a restart of my machine, and occasionally, changing which usb port the keyboard is plugged into. Usually Dorico is smooth as butter for me since I don’t have huge projects, but it is absolutely crippling when this happens.

That’s interesting!
Mind you, on my video I’m not even inserting the notes via midi keyboard, but rather using the computer keyboard.

The crashes are an OpenGL driver problem in an older version of NotePerformer, which I believe is fixed in the current version.

Thanks for chiming in, that’s good to know! (even though I thought the playback instance is separate from Dorico itself).

Is this also the cause for the unbearably laggy behavior? Because it seems to be laggy even when playback is off.

“Silence” is my default setting and it’s extremely rare that I ever load a vst in dorico, so I doubt it.

Looks like a cool piece! I notice in the original file that the System Track is turned on, as well as condensing. I usually turn off both of those when I’m editing a piece; I know that condensing slows things down, and I think the System Track can slow things down as well. FWIW I tried a few simple edits on my 2019 MacBook Pro and they worked just fine.

2 Likes

Thanks for your suggestions. When I turn off condensing, hide the system track, and turn playback off, there definitely is some improvement, and yet, still everything feels heavy.

It’s looking more and more like the issue is the interaction between the project and my computer rather than my computer or the project independently.

In any case, good to hear from you Stephen, we should catch up soon

1 Like

Echoing Paolo’s post, I have tried several edits in your file for about ten minutes and they were all near instantaneous - with condensing still on to boot. I have a Ryzen 3700 with 32 gigs of Ram. I realize it’s of very little help, but I would feel remiss if I didn’t at least report it.

Great piece!

My computer (with 2 cpus and 32 cores) is not likely the issue, and it seems that the project itself is not the issue.

So maybe it’s the installation? I’ll try to uninstall / reinstall and see what happens.

Update:
I uninstalled and re-installed Dorico and Note Performer
This has not fixed the issue :frowning:
All I can hope is that this issue is not something that will infect any of my other projects. Other projects seem to be doing much better in terms of speed

What I wanted to try was to export your file as an xml and then reimport it - thereby stripping it of most of its special notation - to see if your lag was due to a graphics, or an edited symbol, or any such similar detail. But in the end it was not worth doing because I experienced no lag. Perhaps you should try it.