Up and down cursor not editing my midi notes

Hi,

Hopefully this isn’t just a stupid question, but my arrow keys have an issue and preferences seems to be not behaving as expected. My first symptom was that up/down was not moving notes in the midi editor, however left and right behaves as expected. In the Project window, Up+Down only navigates tracks. I went into preferences and checked/unchecked “Use Up/Down Navigation Commands to Select Tracks Only”, but this doesn’t change anything. I’ve also tried reverting back to the default key commands to make sure it wasn’t a key command issue. Any ideas? Is there a setting I’m missing? Thanks

Hi,

Are you sure the focus is in the Key Editor? Is there a white frame around the editor? It sounds like the focus is in the Project zone, to me.

it’s been fixed in 9.0.20 :wink:

I have the same problem. This problems appear from time to time and i dont know why. The midi section is highlighted as it should, but Arrows select next track instead of moving midi. Very frustrating, please help. :cry: :nerd:

I’m not sure exactly what i’ve done, but when i use up and down arrows to try and move my midi notes instead it ignores the midi notes and scrolls along my tracks, i’ve double double checked that “Use up/down commands for navigating tracks only” is not checked, its definetely 100% not checked, still when editing my midi files the notes won’t move up and down. If i use left and right the notes move as expected.

Any other place i need to check to get my up/down arrows to edit my midi notes again?

Thanks!

Not in front of Cubase at the moment, but isn’t this an assignable keyboard shortcut? Maybe check under preferences.

I’m not sure what happened, but after a restart it seemed to start to work as expected, so, really unsure as to the cause of that!

I have seen his exactly, with the same cure, but haven’t found a repro. If you find one please be sure to post here.

So I finally found out how to solve this without restarting the project, it seems to have something to do with the channel settings window.
After closing and reopening it, it worked again.

I want to take this opportunity to say that the cubase support is the absolute worst and that the people leading this company are doing a very bad job.

Hi,

Could you be more specific, please? do I understand you right, the Channel Settings Windows has been opened? On the other screen or the same screen? Did the focus jump over to the Channel Settings Window? Is it reproducible?

In my case the Channel Settings Window was already open on another screen, and when I closed it and reopened it everything worked fine again.

I don’t know how to reproduce the bug, but I happened again a few minutes ago it closing and reopening the channel settings window worked once again.
No idea what is causing this, though.

Hi,

When this happens (so the focus is not in the Key Editor anymore), is the focus in the Channel Settings window then?

Was the Channel Settings window the last one in focus, before you opened Key Editor?

no, the focus was OK but after an update it seemed fixed.

Ah, this is still happening, i came to find out how to solve this, happened to me a few times that thankfully now i’ve found out that if the channel settings window is open then it somehow doesn’t give focus to the midi editor even if the channel settings is in the background, the up+down arrows just move the track selection in the main window up and down, i’m reading here it was fixed, but, yeah, it still happening on my PC at least.

Hi,

I would like to link this same thread here.

Done!