Update on screen lag & freezes

Originally posted here: https://www.steinberg.net/forums/viewtopic.php?f=291&t=162116

Yes, have posted about this a number of times before: slightly different context - screen updates freeze regularly, every few minutes or so, the freezes happen twice, then wait again for another few minutes. In general, audio continue to play but am locked out of any editing, mouse or control surface functions. This happens on such a regular timing cycle that it feels like some kind of ‘polling’ by Nuendo.

Finally, I should add that the computer, drivers, OS etc are all optimised and working well (& without going into endless Q&A about versions, tech details etc). The main point is: this behaviour does not occur with any other program except for Nuendo: that includes Pro Tools Ultimate 2019.5, Ableton Live Suite 10.1, Studio One 4.5 & far more demanding NLEs for that matter, eg: DaVinci Resolve Studio.

EDIT & UPDATE: 27 Oct 2019
Went back to this and dug deep after very annoying performance on a film project:

  • went through all the usual: clean install, fresh prefs, minus 3rd party plugs, optimised Win settings, etc etc. None of this made any difference, behaviour exactly as per above post.

Overall, I have now found that this is 100% related to GPU & drivers. Without getting into ancient raves about ‘audio production & GPUs’ - it is 2019, and many of us need and use high end GPU tech for other important studio rendering requirements like for film prodcution, music-to-picture etc. AND, this is Nuendo (10.2) which is meant to be designed for pro POST.

Now, there are many threads about exactly this issue, on the Steinberg fora for Nuendo & Cubase as well as various external production sites. The most common ‘fix’ recommendation that comes up is to ‘disable G-Sync’ via the Nvidia Control Panel. However, the thing is that this option doesn’t necessarily appear, depending on what display(s) are being used. G-Sync (Freesync) monitors are for gaming. In my case, the Displays are selected for 10bit colour accuracy, user calibration & film production - so, no ‘G-Sync’ option (or Freesync in the Displays themselves) though this can still be manually disabled via 3rd party tool, Nvidia inspector

I disabled G-Sync this way (but likely unnecessary because these particular Displays do not use it).

Final fix:
Override the default GPU settings & make a custom profile for Nuendo /Cubase in the Nvida Control Panel: 1) use ‘performance mode’ and 2) turn off V-Sync (this produces lag). The problem has finally gone. Other Nuendo settings FYI: no auto save, no auto hit-point detection, Steinberg power scheme, Hi DPI, 64bit processing. All good, at last.

Hopefully this might help someone else.

Dude, you are absolutely awesome :slight_smile:
Thank you so so much for your final fix post. I literally lost all motivation to use Cubase with these massive frame drops. Now I set the exeption for Cubase in the driver settings to use a fixed frame rate (the max frame rate of my monitor) and the problem was solved. I am the happiest person in the world now :slight_smile:

So it’s not “disable V-sync”, that didn’t really work for me - it’s adjusting the MAX FRAME RATE to the maximum of what you have!! Stupid NVIDIA!

THANK YOU DUDE! Now everything plays back very smoothly!!

Yes finally! Many Thanks!! That fixed the problem for me. I only have the onboard graphics of the Intel i7 8700 (Intel UHD630). Usually runs fine with two monitors for audio, even in 4K. Only Nuendo always has these frame dropouts. It is easily possible to set up profiles for selected programs in the Intel graphics control panel. And here I also had the option of deactivating V-Sync, Anti-Aliasing, etc. for Nuendo. Now Nuendo is finally running smoothly !! Thanks alot!!