[UPDATE, SOLVED]I can't open Dorico 1 or 2 Pro since I installed the later

Every time I try opening either it gets stuck on trying to connect with the VST engine (Timeout). I’m on El Capitan on Mac BTW, I’ve tried deleting the VSTEngine folder in the library folder, as advised in other threads, yet it had no effect.

Could anyone help me? (EDIT: I already tried out reinstalling everything, both automatically and manually, deleting every single installation folder and file related to Dorico or Steinberg to no result)

UPDATE: I found the solution in another thread in Cubase forums. First of all, I’d like to publicly both apologize and thank the Dorico team that have not failed to, at least, pay close attention to my issue, even if they didn’t find the solutions, it was not their fault. Turns out this was the issue: A plug-in was constantly trying to be authorized (Melodyne, in my case, which was caused by an issue). This caused VSTAudioEngine 2 to enter a loop of trying to scan that particular vst3 plugin, which “refused” to be scanned, this was of course followed by a freeze of both VSTAE2 and Dorico following it. How did I know what plugin was causing the issue? I started VSTAE2 on standalone mode, with Dorico closed, and on the progress bar I noticed it got stuck at “scanning VST3 plug-ins…”, so I proceeded to move in and out of the folder (Library>Audio>Plug-ins>VST3) various plugins to check which was specifically causing the issue. Found out, removed it (you could just move it to another folder or fix the authorisation issue), restarted Dorico and everything runs smooth as butter!

I hope this thread serves to help anyone with the same issue in the future

Hurray!!! :laughing: :laughing: :laughing:

Have you tried rebooting in between?
There shall be no problem with having Dorico 1 and 2 installed side by side, though you can’t have them both running at the same time.
If you problem persists, please choose from the main menu Help > Create Diagnostic Report. That will create a zip file on you desktop. Please send to ‘u dot stoermer at steinberg dot de’.

If Alvaro can’t start Dorico then he can’t choose Help > Create Diagnostic Report, alas. But Alvaro, you can go and take a look at the application.log file in ~/Library/Application Support/Steinberg/Dorico 2 and attach that here (zip it up first).


Here you have it, i have multiple logs, ill attach all of them.
Dorico 2 AppLogs.zip (6.27 KB)
OH, i have updated to the lestest version of El Capitan, yet the issue persists.

Thanks for the Dorico logs. They all say that Dorico is waiting for the audio engine.

Could you please also zip up the folder /Users//Library/Preferences/VSTAudioEngine2 ?

Also, under /Users//Library/Logs/DiagnosticReports , are there any crash dump files for VSTAudioEngine2?
If there are, then also please zip them up and post here.

Here they are.
Dorico 2 Crash Dumps and Files.zip (21.8 KB)

There is no VSTAudioEngine crash dump file, but it is mentioned on the lastest vstscanner dump, so they should be related.

This is all most weird. The log files of the audio engine are absolutely empty.
That means that the audio engine must crash or hang immediately after being started.
Yet there are no crash files for the audio engine, you say.

If you open the Activity Monitor utility, in the list of processes, is there any item
called VSTAudioEngine (or similar) listed?

And neither Dorico 1 nor Dorico 2 work anymore?

Have you tried reinstalling Dorico 2?

Yes, there is. And it shows fine at first, then it displays as “Nor responding”, I have tried reinstalling it, yes. Do you recommend I try again deleting some folders manually?

Strange, strange. I suspect it to be an audio device issue or so. What kind of audio device do you have, just Built-in Audio?

And yes, please try to delete the folder /Users//Library/Preferences/VSTAudioEngine2.

And if in the Activity Monitor the VSTAudioEngine Process is shown as not responding, please end the task and try to start again Dorico1.
It is so weird, that also Dorico 1 is not working anymore with you…

I’ll update you as soon as I get back home. I am in fact using Built in output. And as I said, neither Dorico 1 nor 2 Pro respond at the moment. I’ll also try to install Dorico on another user if reinstalling the way you said doesn’t work.

UPDATE: No improvement. Uninstalled (and deleted preferences and other asociated files), deleted VSTAudioEngine folder, restarted, and same error message
Captura de pantalla 2018-06-07 a las 20.21.06.png
. This is becoming a major annoyance, Dorico team, please find a solution ASAP, i got work to do, and as i stated, not even Dorico 1 is working.

Do you have any Izotope plugins installed? A quick google for this error message suggests that it’s an error caused by that.

Yes i do! :open_mouth: I have iZotope Ozone 5 and 8 (recently installed). However! Dorico 1 worked fine before installing Dorico Pro 2, and even then i had ozone 8 installed… Dorico is the only program giving me issues with that though, not even logic or iZotope sofware itself …

Although I’d say this can be something parallel to VST engine timeout, which is the message Dorico still gives me too.

From my google search it appears that this error occurs in other software beside Dorico, so I would check on with iZotope support/forums. If iZotope pops up a message box when the audio engine tries to initialise it, then there’s nothing the audio engine can do (it doesn’t even know that there’s a message up). And if the audio engine is waiting for that, then Dorico waits for the audio engine, and you see it as a hang.

iZotope forums also show up when i search that on google, but im pretty certain it’s just keyword association, because no exact error message as the one i got is found on the forums, particurally if one searches for Mac specifically. In my activity monitor nothing regarding iZotope shows up, and when trying to load VST engine before staring Dorico, as some others have suggested, the exact same thing happens. However I’ll try uninstalling Ozone plugins

Nothing regarding Izotope will appear in the activity monitor because they are plugins loaded by the VSTAudioEngine2 process.

If you find the audio engine log file in


and attach here then this may tell us more about what’s happening.

Just to update you guys @ Steinberg. I’ve installed Dorico on another user with no Izotope plug-ins what soever and yet the issue persists. Plus, the only new Izotope plug-in I installed about the same time as I did Dorico 2 Pro was Ozone 8,which I Uninstalled for this test; it made no difference. Needless to say I’m very disappointed that a solution has to this issue not been found, the only reason I have not claimed or looked for some sort of refund is that I love Dorico and I can use it (worse of course) in my Surface Pro tablet, which is far from ideal.

I’d like to avoid doing a fresh reinstall of OSX just to get Dorico to work…

And BTW, Paul, if you look back into my replies on this thread you will see I have already been asked and uploaded the file you are requesting.

Your problem does seem to be unique, and it’s very difficult to remotely diagnose problems of this sort. But the Steinberg team are giving you excellent support.
As you’ve ruled out user-based issues by testing another user account, that means the cause is at the system level. Are you sure the plug-ins aren’t installed at the system level – in your /Library/Audio folder?

Reinstalling a clean OS X is a nuclear option that’s almost always unnecessary. I would recommend using an application like EtreCheck, which will give you a report of the ‘state’ of your system, listing 3rd-party installed software that might be problematic. You can then try uninstalling or removing those things, and see if that improves matters. You could send the report to one of the Steinberg team, as it might provide useful info for them.


I’m sorry to hear that you’re still having problems on the new system. The reason that no solution has been found is that this problem appears to be totally unique to your system: no other users have reported this problem. We did look at your uploads, but since the audio engine log is empty, that doesn’t give us any useful information.

If you still have that error message about the hook config then we can try digging in to isolate that. Try this: right click on the Dorico app and choose ‘Show Package Contents’ then navigate to the VSTAudioEngine2.app (which I think is in Contents/Applications - I’m not on a mac at the moment so I’m not totally sure). Run the VSTAudioEngine2 app and see if you still see the same error message.

If you do see the message then you could run spindump to capture the state of it while the message is showing. I don’t have the details to hand on exactly how to do that - if you don’t know how to do it then I’ll get the instructions from someone else on the team.

Also sorry from my side, this thread somehow slipped out of my sight…

Regarding the error message “Can’t read hook config resource”, this is something I have never seen and also a Google search does not bring up anything sensible, because it only brings up search results for pages that contain any of the mentioned words, but never the whole phrase. So I also wonder where that error message comes from.

Do as Paul suggests, just run the VSTAudioEngine2 app alone and see if the error message still comes up.

Also, the audio engine will only show a splash screen for a few seconds and after that has no UI because it runs in the background. So please start Activity Monitor and in the list of processes have look for an item “VST Audio Engine”. Highlight it and then at the top of the Activity Monitor window is a little cog wheel; click on that and choose “Spindump”.
Please send the dump to ‘u dot stoermer at steinberg dot de’.