Updated from Cubase 5 to Cubase 10.5 usb connected keyboard not working now

Hiya, if anyone can advise that would be really great.

I’m using Windows 10 latest version.

I’ve just upgraded from Cubase 5 to Cubase 10.5 Studio version and my musical keyboard is not working triggering anything at all now on the keyboard inside this new version of Cubase.

The keyboard - Evolution MK-361C keyboard still works perfectly fine with this old 32bit version of Cubase 5 on the same machine.

I upgraded from Cubase 9.5 which was also working perfectly fine using Windows 10 with my keyboard which is an old Evolution MK-361C to 10.5 Studio.

I just can’t get the keyboard to work now in Cubase version 10.5.

Drivers for the keyboard are automatically installed via Windows when plugging it in.

I’ve replicated everything regarding the previous settings I have from Cubase 5 (32 bit) and Cubase 9.5 (64 bit) in the latest version 10.5 however nothing is working to make the keyboard trigger actions within this new version.

I just want to get my old Evolution MK-361C keyboard working again.

I’ve previously been using a Magix Low Latency 2016 ASIO driver which has worked perfectly fine with no lag at all in Cubase in the previous versions.

I just can’t get this new version of Cubase to work now with my keyboard. Tried the ASIO4All driver and that is not working either.

If anyone can advise or point me in the right direction to any settings to any changes I need to make after upgrading to 10.5 that would help a lot with updating from the earlier to the latest version.

Cheers,

Mack

Hi,

Can you see the device in the Studio > Studio Setup > MIDI Port Setup?