Upgraded to Mac 12-core, have same ASIO/CPU in Cubase

Yeah agreed thats simply not true. Remember, it’s only since we moved to 64bit Cubase could fully make use of extra RAM.

What does your project consist of? Have you narrowed it to some offending plugins perhaps? Are you using any bridged plugins?

Also if you’re vst and sample heavy might I suggest using the trash can as a slave than a master?

Just for fun/test, I inserted 200 VST instruments/midi loops with fx and Cubase pro 8.5 VST Performance was at 75%.
With 100 VST instruments, at 50%, an excellent performance in my book. Steinberg delivered on their promises.

Hmm.
I am currently on a quad core and intending to upgrade though now i have reservations.
Steinberg has made big improvements and its engine is certainly quite good at cpu consumption,maybe even at the top with Reaper,though i havent tested anything with more than 4 cores. Funny thing is in the end of 2016 we can expect major breakthroughs in cpu development,as both Pentium and AMD will reveal new line of cpus.
AMD claims to have made a 32 core cpu for a single socket,engineers at CERN have already tested it,supposedly it`s a beast.

I totally understand your position and frustrations.
Like ive said i havent tested with more than 4 cores so you have a better perspective than i do.
Still i hope Steinberg fixes some obvious multi cpu support issues with Cubendo.

This has been a growing frustration for me, too. Reaper 5 eats Cubendo’s lunch in all areas of performance:

  • launch time
  • project open time (very slow on Cubenco 8+)
  • VST performance

It feels like Cubase 8+ has taken a big step backward in performance, and reliability. Reaper doesn’t crash. Cubase does. I can’t close a project and open a new one unless I restart Cubase or it will crash. I recently had to open an old project with 7.5 and it was definitely snappier all around.

Long story short, there are features in Cubase that I’ve come to rely on (VST Expression, Note Expression, VST SystemLink), but the performance and reliability are killing workflow.

Besides performance, Reaper has some great features that no other DAW can touch (Project-in-Project, multiple open projects/tabs, automatable playback rate, take FX/envelopes, free item positioning, scripting!, …). I’m using it more and more and using it in tandem with Cubase, but it’s a real drag that the company who invented VST doesn’t have the leanest fastest audio engine. If I had a penny for every time I had to click and clear the overload indicator in the ASIO meter I’d be retired now.

I know that many of you are not experiencing performance issues and I’m envious. This is just what I experience every day. If it weren’t for the fact that Reaper performs so much faster (and flawlessly), I would blame the machine/configuration/OS, but this is a side-by-side daily experience.

Cubase and Nuendo, I love you, but get it together. Steinberg, I’m certain you’re 100% aware of how your engine performs vs the competition. Show us what you got, or you’ll be left on the side of the road. I don’t need another synthesizer and a fancier Groove Agent. Just make the fastest most reliable VST engine on the planet! If not you, who?!!!

Done with rant. Going back to work with Cubase 8.5 rewired to Reaper with Nuendo 7 following along by System Link…

  • Jason

It’s a lot of work to learn another DAW, but if you’re pushed to the limit…

Presonus did rewite their engine to invent Mix bus FX. The scripting in Reaper sounds verry powerfull, steep learning curve allthough. Both got VCA’s now and had visibility option before Cubase if I’m correct.

Thruth is it takes time to find the flaws in their software… But if things are not getting better…

S1 is sort of a toy DAW compared to Cubase it`s not even in the same league.
A jack of all trades and master of none.

Are your cores throttling up and down with the load? In Windows you have to go in the Bios and turn off CPU throttling. BAsically the cores slow down when the are not under load to conserve power… this shows as high ASIO load in Cubase. IF you set the cores so they don’t throttle you have maximum core speed available at all times and you shouldn’t see those “logarithmic” load situations. I might be wrong but this is what it looks like to me.



quote=“Headlands”]

This must be because you have a very high clock rate. Also, take a look at the CPU graph and see which cores are being used – you could probably have a lot more power if Cubase took advantage of all cores (unless four cores somehow works perfectly for Cubase).

It’s easy for Steinberg to say “Just use a CPU with a higher clock rate!”, but that’s not dealing with reality for tons of its users. Let’s say you have a Mac and you need massive processing for other programs like Final Cut Pro, Pro Tools, video graphics applications, etc. – you need the high core-count systems because all of these other programs take advantage of that and Xeons are the only processors you can get for Macs (everyone: please do not start a Hackintosh or Mac vs. PC discussion – this is completely separate from that, and these problems are with any multicore processor on any platform). So if you’re a Cubase user you’re screwed in that case. Since every other DAW many of us have tried here can take huge advantage of multicores/threads and Cubase doesn’t, there’s a very clear fault with the basic engine.[/quote]

I agree it’s a lot of work to learn another DAW. That’s why I stay away from Logic… I’m also happy with Cubase :slight_smile:
Cubase I now embedded in my brain/songwriting process. I work extremely fast with Cubase. When you can write
Lyrics in the morning and have a pro song completed with a rough mix in 8 hours and know excactly how and seamlessly. Without technology getting in the way. Cubase also works like an analogue studio. You can’t beat that.

Cheers :smiley:

I agree, that is had the same issue. The latest multi core motherboards, haswell system in my case do not perform as well a the 4 core systems, I had to send 2 six core i7 pc 's back after spending two months trying to resolve why I no longer could run big templates. At first I thought the first one was a Lemmon , but the second PC same issue ( asus x99 motherboard system ) I didn’t compare to other daws.

With the specs below ,Cubase 8.5, win 10, and a brand new motu AVB card it’s going much better now…

On some systems Cubase is a beast - on others it’s a dog. Steinberg really do need to pull their finger out - Reaper and Mixbus fly on my system - I never run out of CPU before I run out of talent - I’ve had terrible CPU issues with Cubase - although the last update seems to have fixed the problem to the point where Cubase is now usable for me again on larger projects - for the first time since Cubase 7! I love Cubase but I was really close to ditching it.

+1

thanks @headlends for your tests and posts.

I just upgraded from an iMac 3,6, 4 cores, 8gbRAM to a macpro 2x3,4, 6cores, 64gbRAM and thought I was going crazy NOT having the performance boost I expected.

Also I was experiencing the “plugins on tracks” VS “same plugins via busses and fxs” myself and you confirmed it. No routing/no send fxs is a despicable option…

Beside the investment bummer now I’m also wondering if I should get back to PT

Wish I had found this before… http://www.steinberg.net/en/support/steinberg_support_daw.html

[…]

  • Processors with faster cores are preferable to a higher core count for real-time audio performance.
  • The more cores are available, the more thread synchronization is required. This can lead to a reduced processing power and slow down the system after all.
    […]

I think also this is around the same subject (let google translate it for you)

https://www.steinberg.net/de/support/knowledgebase_new/show_details/kb_show/hyper-threading-and-asio-guard/kb_back/2025.html

Regarding disabling the hyperthreading to achive better performance, which I think is related to the multicore processing. (but I think the doc is old…)

I hope stienberg is monitoring this thread and taking this issue seriously. I am in post production with an album and now that I am getting into 40 audio tracks, cpu having drop outs when automation bypass turns off for a FX track with waves plug in Gtr mono…this should not tax my system

Apparently other developers have figured out how to make more cores give you more power. Logic runs circles around Cubase on my 12 core Mac.

Exactly.

Maybe this article is old, and the hypethreading issue is not an issue anymore. But the “bottleneck” (for a lack of better word) that Cubase goes through regarding CPU usage seems to be a reality.

In my case, thanks again to @headlends, it opened my eyes spotting where the problem was, and I’m now comparing with PT11, packing a session with plugins on tracks and aux tracks, and getting the results you would expect from my machine.

+1 on getting Steinberg on this.

Gius

Hello,

users who notice no improvement or even a drop in performance when upgrading the CPU/system, please get in touch with support, this is by no means normal.

Some recent, related discussions can be found here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=98601 and here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=98409#p544271
The issue at the first link was eventually solved by rolling back the BIOS to the previous revision, F21 instead of F22 - quite a rare occurrence, but perhaps useful to some. The second contains some info/links about multi-core operation.

Windows users could try to disable the usual BIOS CPU trimming options (Turbo-Boost, Enhanced Halt, all C-States, Speed-step - naming may vary, please check the mainboard manual), in the OS: set Power Options for High Performance, disable HD and USB sleep, install only the GPU driver, avoiding the control panel (where applicable), 3D controllers and such.
It is worth to check the RAM timing as well: please, make sure that you are running at Intel’s recommended specs for the chipset/CPU in use, if overclocking (not recommended), make sure it’s an even ratio of the FSB speed. Also make sure that the modules are running at their ‘native’ speed (there are a few 1600MHz modules that are detected as 1333MHz and will run at that speed - this can cause both crashing and bad performance, it actually happened to me on a general purpose rig I assembled). A good course of action is: reset to safe defaults, check the RAM timing, then disable the above CPU frequency (many mainboards allow to save your profile, you might want to do that before loading safe defaults).

When all fails, please get in touch with support.
On Mac it can be a little harder to trouble-shoot, I’d advice to get in touch with support straight away.

Different applications can have different performance, with one or the other working better on some systems and worse on others, it’s all down to understand why and take action as different software implementations and frameworks will yield different results. Not referring to Logic here, as it does not use neither ASIO nor VST, they’re not really directly comparable.

+1 on MAC here.

I seem to have the exact same scenario as @headlends