Upgraded to Mac 12-core, have same ASIO/CPU in Cubase

I agree, that is had the same issue. The latest multi core motherboards, haswell system in my case do not perform as well a the 4 core systems, I had to send 2 six core i7 pc 's back after spending two months trying to resolve why I no longer could run big templates. At first I thought the first one was a Lemmon , but the second PC same issue ( asus x99 motherboard system ) I didn’t compare to other daws.

With the specs below ,Cubase 8.5, win 10, and a brand new motu AVB card it’s going much better now…

On some systems Cubase is a beast - on others it’s a dog. Steinberg really do need to pull their finger out - Reaper and Mixbus fly on my system - I never run out of CPU before I run out of talent - I’ve had terrible CPU issues with Cubase - although the last update seems to have fixed the problem to the point where Cubase is now usable for me again on larger projects - for the first time since Cubase 7! I love Cubase but I was really close to ditching it.

+1

thanks @headlends for your tests and posts.

I just upgraded from an iMac 3,6, 4 cores, 8gbRAM to a macpro 2x3,4, 6cores, 64gbRAM and thought I was going crazy NOT having the performance boost I expected.

Also I was experiencing the “plugins on tracks” VS “same plugins via busses and fxs” myself and you confirmed it. No routing/no send fxs is a despicable option…

Beside the investment bummer now I’m also wondering if I should get back to PT

Wish I had found this before… http://www.steinberg.net/en/support/steinberg_support_daw.html

[…]

  • Processors with faster cores are preferable to a higher core count for real-time audio performance.
  • The more cores are available, the more thread synchronization is required. This can lead to a reduced processing power and slow down the system after all.
    […]

I think also this is around the same subject (let google translate it for you)

https://www.steinberg.net/de/support/knowledgebase_new/show_details/kb_show/hyper-threading-and-asio-guard/kb_back/2025.html

Regarding disabling the hyperthreading to achive better performance, which I think is related to the multicore processing. (but I think the doc is old…)

I hope stienberg is monitoring this thread and taking this issue seriously. I am in post production with an album and now that I am getting into 40 audio tracks, cpu having drop outs when automation bypass turns off for a FX track with waves plug in Gtr mono…this should not tax my system

Apparently other developers have figured out how to make more cores give you more power. Logic runs circles around Cubase on my 12 core Mac.

Exactly.

Maybe this article is old, and the hypethreading issue is not an issue anymore. But the “bottleneck” (for a lack of better word) that Cubase goes through regarding CPU usage seems to be a reality.

In my case, thanks again to @headlends, it opened my eyes spotting where the problem was, and I’m now comparing with PT11, packing a session with plugins on tracks and aux tracks, and getting the results you would expect from my machine.

+1 on getting Steinberg on this.

Gius

Hello,

users who notice no improvement or even a drop in performance when upgrading the CPU/system, please get in touch with support, this is by no means normal.

Some recent, related discussions can be found here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=98601 and here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=98409#p544271
The issue at the first link was eventually solved by rolling back the BIOS to the previous revision, F21 instead of F22 - quite a rare occurrence, but perhaps useful to some. The second contains some info/links about multi-core operation.

Windows users could try to disable the usual BIOS CPU trimming options (Turbo-Boost, Enhanced Halt, all C-States, Speed-step - naming may vary, please check the mainboard manual), in the OS: set Power Options for High Performance, disable HD and USB sleep, install only the GPU driver, avoiding the control panel (where applicable), 3D controllers and such.
It is worth to check the RAM timing as well: please, make sure that you are running at Intel’s recommended specs for the chipset/CPU in use, if overclocking (not recommended), make sure it’s an even ratio of the FSB speed. Also make sure that the modules are running at their ‘native’ speed (there are a few 1600MHz modules that are detected as 1333MHz and will run at that speed - this can cause both crashing and bad performance, it actually happened to me on a general purpose rig I assembled). A good course of action is: reset to safe defaults, check the RAM timing, then disable the above CPU frequency (many mainboards allow to save your profile, you might want to do that before loading safe defaults).

When all fails, please get in touch with support.
On Mac it can be a little harder to trouble-shoot, I’d advice to get in touch with support straight away.

Different applications can have different performance, with one or the other working better on some systems and worse on others, it’s all down to understand why and take action as different software implementations and frameworks will yield different results. Not referring to Logic here, as it does not use neither ASIO nor VST, they’re not really directly comparable.

+1 on MAC here.

I seem to have the exact same scenario as @headlends

My test with CBS (followed by my test with PT11)

Same amount of plugins, different CPU loads.
CBS8.5_C_1-AUDIO-AND-2-AUX-IN-SERIE-8-PLUGS-EACH.png
CBS8.5_B_3xSTEREO-AUDIO-TRACKS-8-PLUGS-EACH.png
CBS8.5_A_24xSTEREO-AUDIO-TRACKS-1-PLUG-EACH.png.png

Here it goes. The same 24 plugins in different combination and the CPU load going to the roof in PT11 too… :frowning:
PT11_A_24xSTEREO-AUDIO-TRACKS-1-PLUG-EACH.png.png
PT11_B_3xSTEREO-AUDIO-TRACKS-8-PLUGS-EACH.png
PT11_C_1-AUDIO-AND-2-AUX-IN-SERIE-8-PLUGS-EACH.png

You should email Steinberg that

This has also been my experience over the years. My suped-up 4-core beats my 12-core; both with tons of RAM and SSD drives.

Also my experience, as well.


Interestingly I found Cubase’s inefficient multiprocessing has bizarre ceilings. For example, I can load about 50 instrument tracks, each with one Kontakt instance and ASIO load steadily increases to 20-50% steady load. But once you reach a certain threshold, say 55 instances (it varies depending on the machine and other factors, but generally you can predict around what track count), the ASIO meter will go insane and max out and the whole session grinds to a halt. This behavior is exhibited in the best of circumstances (the right ASIO Guard settings, buffer settings, etc) and only goes downhill if any of those settings are less than ideal.

In contrast, I can load (and play) 200 Kontakts inside of Logic Pro X without much problem. Also, VE Pro can take dozens if not hundreds of Kontakt instances.

So yes, there is something amiss with Cubase’s internals. I just find workarounds - disabling instrument tracks I don’t need, offloading some things to VE Pro, etc. Frustrating but I’ve lost hope that the situation will improve without a total rewrite of Cubase.

This basically sums up my position. I need Cubase’s workflow because I prefer it to any other DAW. But its inherent instability in the face of competing DAWs has made me form a love/hate relationship with it.

Now, this post got me completely confused…
Most people say that the issues discussed in this thread are only happening in Cubase and the post i quoted states, that it’s the same in PT 11 o_O

Btw: Did anybody include Ableton Live in their comparisons or kniws how it handles multicore vs. clock speed?

Count me in. I use CP8.5 and I have the same issue on i7 Windows 10 pro with a HDSPe MADI FX soundcard. See attached file related to my current big session : Proc 0 is 100% when the others proc are almost quiet.

I wish a new Cubase Pro 9 with ONLY multi-thread performance upgrade and less crashes on WIN10. Nothing more. Period.

But… I have a question for those who have a 32Go DDR RAM system with cubendo:
My system absolutly never seems to be able to use more than 8Go from my 16Go DDR3 config (2*8Go DDR3) :cry: How can I deal with that ? See attached file…

Any help or advice ?

Thx!


You could try opening the task manager and set the cpu affinity of Cubase to not run on cpu0.
That usually helps.

Ableton seems to handle it the same way Cubase does:https://help.ableton.com/hc/en-us/articles/209067649-High-CPU-load-on-one-core-when-using-multi-core-machines

Hmmm, I’ll keep track of this topic, as I was thinking of maybe upgrading my 2006 Mac Pro 8 core to a (used/refurbished) 2012 12-core… :confused: