Upping format messed up the timing of events and speeded them up

This is so frustrating. It asked me if I would like to keep events at their sample positions, I chose yes. It’s very confusing. What does this mean?

I went from 44 to 48

I did not save the project luckily, and retried and this time chose no to keep sample events at their position and that fixed it. What does that do

That option keeps audio files at their sample position as it says.
Let’s say you had a sample at bar on a 44.1Khz project at 120BPM, 1bar at the tempo is 88200 samples long, so the originally the sample is at sample position of 88200.
On changing frequency to 48Khz, the bar will be 96000, and if you enable the option, the event won’t move from the original position that is 88200, so that it moved earlier in musical position because 48KHz uses more samples per second. Usually the result is unusable.
It is important to have that option there for cases when fixing problems caused by SR changes. It should be informed better though.

1 Like

Thanks. I really appreciate the response. Have a good one

1 Like