UR interfaces audio drop outs (follow-up thread)

After spending a ton of money upgrading to x99, you can imagine my near apoplectic rage when I discovered I had this problem, especially after nearly 4 years of flawless performance on the x79 platform.

However, I seem to have fixed my issue (will report back if I happen to be proven wrong any time soon), so for the sake of helping of even one person, I’ll first post my system components, then detail my fix.


i7 5820k OC’d to 4.3ghz on an MSI Gaming7 X99a motherboard
MSI GTX 970 ME
32 gigs of G.Skill Ripjaws 4 series DDR4 RAM
Netgear A2600 wireless adapter
Windows 10 Enterprise edition
UR824 interface

I haven’t even installed my DAW or plugins yet, and I was getting dropout in playback from Foobar, as well as whatever the crap that new Windows music app is.

Two things appear to have worked for me, though I suspect the latter is probably the true fix.

Run this utility
http://www.coderbag.com/Uploads/Unpark-CPU-App.zip

and unpark your cores.

Also, go to Power & Sleep>Additional Power Settings>(select)High Performance, and then Change Plan Settings>Change Advanced Power Settings>Processor power management, and set minimum and maximum processor states to 100%

Now, it’s highly likely all I just did was provide you with a guide to unparking your cores and giving your system as much CPU horsepower as Windows will allow, but what I suspect mostly did the trick for me is, drum roll…

Switching to a USB 2.0 port. Specifically one of the ones on my case front connected via the jumper section on the motherboard (not the mobo’s hardwired 2.0 ports, which are occupied by my mouse and keyboard for the sake of cord length).

Will see what happens after I install audio software and put this puppy through it’s paces, but for now my problems appear to be solved.

At some point, I plan to try a PCIE USB 2.0 adapter card so I can free up the occupied 2.0 port on my case front, so I will report back with that finding as well, though it make take a while due to my current financial quagmire.

Hope this helps,

Cheers!

UPDATE

While this fix worked for several hours for me, eventually the problem returned.

I’m going to to test the system with a Focusrite 18i20 over the next few days, will report back findings.

:slight_smile:

I wait since 9 days for an answer from the support related to my ticket!

Unit not able to use without issues and the support don’t reply yet…

Honestly?

Mike

It took over 2 weeks for them to reply my support request. And then i was directed to the forum and this thread. If that “helps”. :unamused: Not sure, i was always content with their support, usually it was quick and competent, but that was a bit weird i must admit. Don’t expect a solution, that’s all i can say.

Not nice!

Update from my previous post:

Testing with an 18i20 was inconclusive, as I was unable to even get the 18i20 running.

HOWEVER, and I hesitate to even post this, lest I jinx myself, but I believe I’ve located the issue and it is with Intel’s networking drivers for their integrated LAN hardware. Uninstalling the device from Device Manager fixed this for me (fingers crossed that I didn’t just jinx myself).

Hope this helps!

I found the solution for me:

First I used the UR22mkII with my ASUS N55SF Laptop without any issue ever. for months.

Then I upgraded my PC with a new motherboard/CPU and a new graphics card and connected the interface.

There I had drop outs pretty often especially while gaming, but also when just listening to music sometimes.

I tried powering the interface externally and got a quality USB cable but this didn’t help a lot either.

Then I got myself a new power supply. First a LC-Power. This already solved the drop out problem, but I had to exchange it because of noise.
Now I have a beQuiet 850W power supply.

I have since NEVER had any drop out anymore.

I really think you guys should consider a power supply, even if you are not on a limit power wise.

Hope this helps a few of you.

Thanks for the hint, tagomago! A faulty or even just insufficient power supply can be the reason for many errors and crashes on a system. Make sure to have a PSU with enough headroom.

I just bought a ur22MKII, and Im having same issues with a Dell laptop, integrated Intel graphics, Win 10 64 bit, 8 gb ram. My previous interface was a cheap Samson usinG asio4ALL, but it worked fine. Now I cant watch youtube videos without repeated dropouts, and the dropouts also occur in Bias FX. The USB light blinks when the audio drops. Ive disabled everything I can, all power management, Speed boosts, etc. Tried all 3 USB ports. Tried old driver and new. Different USB cable. I cant disable my wifi, because i use it. And my internal sound card can play videos and music fine, so this one should at least be able to do that. Disappointed so far. I hope theres a solution,

You could at least try it, and see if it’s working without dropouts then. Mind that you have to disable your wifi adapter, not your wifi.

I’ve been researching/troubleshooting this audio dropout issue for hours, frustrated that I was getting the dropouts right out of the box. I was about to give up and get something else because I figure if you buy something that’s “supposed” to be good, generally it should work properly and be good… and I’m obviously not the only one dealing with this issue. Anyway, I hope I’m not jumping the gun here but after about giving up I switched out the USB cable that came with the unit for the one I was using previously with my Line 6 UX1 (because I knew it worked at least)… and so far, after about 30-45 minutes of listening to audio I haven’t had any dropouts. I seriously hope it stays this way. If that was the fix, it’s good but very frustrating still, especially that something that seems so baffling could be so simple. Just throwing this out there to see if it helps anyone else.

Are you using the 22 or which model?

Hi guys,

I decided to make an account to share my experience with the UR22mkii.

I purchased one last week, and out of the box, it was dropping out.
The USB light would flicker at the time of dropout and was exactly the issue that was being described in the previous thread and in this one.

Sometimes it will last 3 minutes, sometimes 5 seconds, then a dropout, intermittently for 1-2 seconds.

I tried just about everything I could.
I followed various ideas in the thread, I tried using a wall adapter for the power, I tried updating drivers and managed to crash my OS of Windows 10.
I spent 4-5 days trying to work it out, I almost returned it as DOA.
Then I tested it on an old mac laptop running Windows 10, and it worked without issue.

After trying just about everything software wise, I decided to try a new PSU for my PC.
Just like that, the dropouts are gone.
I had a 500W PSU in my system (a few years old now).
I bought a cheap, new 600W PSU for $40 AUD.
Fitted it and the interface is running flawlessly in Windows 10 now.

Seriously, if it’s dropping out, try the power supply.
My machine was built in 2007, and it’s still going strong.

Don’t listen to anyone try to tell you it’s software/buffering issue, no.
I had someone trying to tell me it was the AMD processor/buffering issue.
Go with your gut.

All the best.

Cam

Hello,

I just bought this soundcard. I also have random cuts sounds

My system :

Windows 10 Pro (clean install)
Intel i5 3570K (no overclock)
Motherboard: MSI Z77A-G45 (last BIOS)
16 Go DDR3
SSD Intel 330 serie - 240 Go
2 HDD (1.5 To and 2.0 To)

Before buying the UR22 mk2, I listen my music on my integrated sound card to the motherboard (ACL892) with ASIO4All:
http://www.realtek.com.tw/products/productsView.aspx?Langid=1&PFid=28&Level=5&Conn=4&ProdID=284

I’ve never had these cuts.

I followed the instructions on the first page but nothing changes. I tried changing the buffer as well as the sample rate. I also changed the USB cable that is bigger and has a ferrite around. The problem persists.

I just lost € 129 :imp:

Just had a weekend with audio dropouts (for smaller buffers <= 256) on my new UR22mk2, Optimizing Windows 7 improved things a little bit, but still too many dropouts. What really helped finally was to disable the “use multi-core” option in Ableton. This is on an i7-4600U. Now, with multi-core disabled, everything runs fine, down to 64 samples as buffer size.
I don’t know if this is a problem with the Yamaha driver or with Ableton, but I thought I should let you know. Maybe someone else with problems can try this.


LatencyMon results:

REPORTED ISRs

Highest ISR routine execution time (µs): 43,981203
Driver with highest ISR routine execution time: USBPORT.SYS - Controlador de puertos USB 1.1 y

2.0, Microsoft Corporation

Highest reported total ISR routine time (%): 0,336272
Driver with highest ISR total time: USBPORT.SYS - Controlador de puertos USB 1.1 y

2.0, Microsoft Corporation

Total time spent in ISRs (%) 0,431453


REPORTED DPCs

Highest DPC routine execution time (µs): 168,454887
Driver with highest DPC routine execution time: ACPI.sys - Controlador ACPI para NT, Microsoft

Corporation

Highest reported total DPC routine time (%): 3,828749
Driver with highest DPC total execution time: USBPORT.SYS - Controlador de puertos USB 1.1 y

2.0, Microsoft Corporation

Total time spent in DPCs (%) 4,598727


PER CPU DATA


_
CPU 0 Interrupt cycle time (s): 1,041409
CPU 0 ISR highest execution time (µs): 32,778195
CPU 0 ISR total execution time (s): 0,086024
CPU 0 ISR count: 51867
CPU 0 DPC highest execution time (µs): 168,454887
CPU 0 DPC total execution time (s): 0,848781
CPU 0 DPC count: 118734


_
CPU 1 Interrupt cycle time (s): 0,831271
CPU 1 ISR highest execution time (µs): 43,981203
CPU 1 ISR total execution time (s): 0,063129
CPU 1 ISR count: 17735
CPU 1 DPC highest execution time (µs): 165,315789
CPU 1 DPC total execution time (s): 0,740999
CPU 1 DPC count: 43013


Hello,

I have similar problems with my brand new UR22.

System description:

Dell Studio 1555 @2,13 Ghz - 4GB RAM - Windows7 SP1 64bits - Intel Mainboard - Yamaha driver 1.9.8

Things that I experienced:

  • Random audio cuts with Ableton Live 9.6 or Cubase AI 8.
  • Duration: 2 to 5 seconds, Rate: 1-3 per minute aprox @ 44100Hz, 1024bits. Sometimes they don’t happen for minutes and sometimes I have 2 or 3 in a 10 seconds interval. Normally the sound is faded out and in (no hard cuts).
  • Very rare audio cuts when using Winamp, Windows Media, VLC and other players.
  • No sound cuts with internal audio (disconnecting the UR22).
  • No CPU load problem: the VU meters are working and reproduction not stopped (with Ableton Live,
    Winamp, etc), but the audio is not reproduced by the UR22.
  • Same problem observed using the headphone output of the UR22.
  • LatencyMon results: USBPORT.sys and ACPI.sys (see details below)
  • I can’t see any related events or processes taking more CPU or memory when the sound cuts happen.
  • I can’t really see any relation of the audio cuts with midi or key events, but they happen more often when the activity is higher (recording instruments, play-stop, etc).
  • I can’t see any dependency between the audio cut rate and the buffer size.
  • There are lots of additional of audio cuts of different nature (shorter duration, with cracks and pops) if I activate multicore processor in Ableton CPU options.

Things that I already tried and didn’t help:

  • Loading the GPU (video acceleration) seems to prevent audio cuts for a while, but I’m still not sure how to reproduce it.
  • Using different USB cables and USB ports (all 2.0)
  • Updating drivers, BIOS, disabling unnecessary HW (wifi) and Windows services, antivirus, windows
    update, etc.
  • Changing windows energy options (processor minimum state at 100%), etc. Selecting “maximum performance” power mode didn’t help.
  • Changing Ableton process priority to high.
  • Using 5V power source of UR22.
  • Using laptop only with battery / AC adaptor.

Can someone help me, please? I am losing a lot of time with this issue!

Cheers.
Antonio

I’ll join the thread. Just bought the UR22 mkII and when monitoring with headphones via the UR22 headphone jack I’m getting regular dropouts every few seconds, regardless of whether it’s from my DAW, or youtube, or any sound file.

What I’m trying to do is play my Roland TD9 electric drums and record as midi, triggering EZ Drummer 2 software into Cubase LE AI Elements 8, on my laptop. My laptop is a Dell Vostro, 8GB DDR3 sdram, running 64 bit W7, dual core i5 2410M 2.3GHz with turbo speed up to 2.9GHz and onboard HD audio soundchip and IDT audio control panel.

The UR22 is unusable because as I record (or just listen) it cuts out randomly. I’ve tried with 5V power supply plugged into the wall. Used a different USB cable 28/24. Swapped between the built in Intel graphics and the AMD graphics in my laptop. Disabled the wi-fi network card. Closed down all browser windows. Don’t know what else to do and if I should return it (I’m still within a 30 day return period) and buy something like a Focusrite 2i4, if that might make any difference?

Someone on another forum suggested I should upgrade to windows 8.1 or 10 as the architecture changed to handle sound differently.

However, when I use the ASIO4ALL driver, I don’t get any dropouts. Sound quality seems about the same to me. But I can’t monitor from the UR22 headphone jack, I have to monitor via my laptop jack, and also I have no control of volume without using the UR22 headphone jack. But by using ASIO4ALL, it means I’m just using the Steinberg as a midi interface, and I just returned a Roland UN-ONE midi interface to buy an audio interface, ie, the UR22.

Ok, another one joining the club(Horrible dropouts every 5-10 seconds on UR22.
I had UR22 for more then a year and it was fantastic on my old computer I5-750, mb GB P55-UD3, 4gb ddr3 generic RAM, Corsair PSU. Just few days ago upgraded to i5-6600K, ASUS Z170-AR, Ripjaws 5 DDR4 3333Mhz 2X8GB.The rest is the same- same GPU, same harddrives (SSDs and HDDs)same Windows 7-64 sp1 (clean install after upgrade).And UR22
is just bad.Dropouts everywhere- in Cubase AI8, in browser…Tried everything- BIOS tricks described earlier here, different USB cables, unplug everything, disable everything, unable everything…I`m tired.Should I trow away UR22 or new motherboard?))) Hope, someone comes with solution to this nightmare.

Hi there. Having lots of problems with UR22. Ive sent my first post yesterday but for some reason its not here…well,Ill try to be quick. Had UR22 for more then a year with my old computer ( i5-750, GB P55-UD3, 4gb Generic ram) and it was fantastic. Last week upgraded to i5-6600k, ASUS z170-AR, 2x8gb Ripjaws 5 DDR4, and having problems with UR22.Dropouts every 3-5 seconds in any applications- Cubase AI8, Youtube and so on. After dping all the tricks and messing with drivers came to this- all usb2 and 3 sockets still have dropouts. Only when I connect UR22 to lan usb31-ea2 (supports usb 3.1 boost) I dont have any dropouts, but have lots of crackling sounds. Don`t know what to do anymore.

UR22Mk2 - Drops out randomly once every 5/10 minutes with windows media player or wavelab 9.

Mainboard: ASROCK N3700 ITX
16 GB Ram
Intel processor (4 core) 3700 1,60 GHZ
Win7 SP1 64 bits

I tried drivers 1,9,4 and 1,9,8, no change.
I tried different cables, external power supply (regulated 5V), different USB ports, usb2, usb3 of the mainboard.

The problem does not occur with the Realtek onboard audiointerface or with a Zoom R16 used as audio interface.

It´s going back to the shop tomorrow. Good luck.