Ur12 + iPad or iPhone I just get blinking

I plugged my unit into wall power turned on my iPad and then plugged in the cable to the UR12 - the light continues to blink and the unit is not recognized.

Big project today… Please advise.

I just got my UR12, and had a similar experience at first. But after unplugging and replugging the UR12 to the iPad, the light went solid. I did this by removing the usb cable from the CCK, not by removing the lightning cable end from the iPad. Not sure if that matters.

Did you get yours working?

Thanks, I’ve not gotten mine working (tried the same trick) and yours is the first reply in 5 weeks. I’d hoped for a response from Steinberg by now.

Thanks for the response.

I tried mine again, and had the problem again, but this time, I took notice of a few things that might be helpful.

When I initially plugged in the interface to the iPad, I got that nasty msg that says that the accessory may not be supported, and the light kept blinking. But here is what I did next, and it worked. With the cable attached, I held down the power and home keys until the iPad restarted. With the UR12 still attached, the iPad booted up, no complaint msgs, and the light went to solid almost right away. After that, I successfully recorded my first little clip (just as a test). Oddly enough, after disconnecting things, using the interface on my Mac for some playback, using the iPad for non-recording things, and then just plugging the interface back into the iPad again, the light went solid almost right away.

So, I’m not sure what is causing it, but it appears that a reboot with the interface attached might be a way to get it working, and it might even work after that without the reboot (at least until what ever is causing the issue occurs again).

Give this a try and let me know if it works for you. Good luck.


Thanks, I will certainly give this a try!