UR12 No Sound Waking From Sleep

I have a UR12, using 1.9.10 drivers, on a Windows 10 FCU machine and every so often when it wakes up from sleep no sound will play through my headphones or speakers even though it is connected and powered - it is connected directly to the motherboard (via USB3 as there are no USB2 ports on the motherboard) so it powers back on at the same time the computer wakes.

Disconnecting and reconnecting it does not appear to do anything, and it’s not practical to restart my computer every time (so I have yet to try restarting), but I have found to get sound to work I have to go into the sound card settings and change the sample rate. There isn’t one particular setting that works, it’s the act of changing that gets it working (e.g. the setting before sleep is 44.1kHz, to get sound working I change to 48kHz so next time it stops working it’s already set at 48kHz and I can get it to work again by changing back to 44.1kHz). This in itself is not desirable as I want to be permanently running it at 48kHz but double changing the setting creates another issue with stuttering sound (which I think is buffer size related so that means I have to mess around with another setting so I just change the sample rate only and leave it at that).

I built this computer around March and it’s been working fine all summer long. I don’t know exactly when this started happening but it was approximately around the time of the Fall Creators update. I don’t use this for any sound production type applications, it’s more of a general purpose and entertainment system so it’s meant to not be messed with and it’s incredibly annoying to have to mess with settings. Does this happen for anybody else? Is there a permanent fix?

Edit: Adding that I have no drop-out or lag issues whatsoever and all my drivers are up to date - notably NVIDIA graphics drivers 388.31 and no NVIDIA audio which some people suspect as a cause of other problems.

It may be that Windows shuts off the USB port to save power. Look into the power setting and disable the “USB Suspend” feature. This could cause the driver to be unloaded or to crash. In my experience, Windows sleep tends to cause problems when things wake back up. I prefer to just shut down the machine so a clean reboot occurs. I have seen touchpads that don’t work correctly after Windows sleep and require a reboot and several audio interface driver problems.

I’ve looked at that but unfortunately it doesn’t stop the problem.

Update: New drivers installed and still happening. This is so annoying!

The BIOS may have a setting that prohibits Sleep Mode. I also seem to remember an option in the power settings in Windows to disable Sleep Mode (or maybe set it to “never”). Just out of curiosity, why is a restart not practical? I like Windows but Sleep has always caused misbehaviors after wake up so I like a fresh boot at least daily.