UR22 cant be found even tho it worked yesterday.

Hello I bought a UR22 yesterday, pluged it into my computer and everything worked fine. Got home from work and pluged it in again and now it cant be found on my computer and wont work, just blinks…
tried to uninstall drivers and install new drivers (1.8.3 and 1.9.0) nothing works.

I’ve tried this solution: http://www.steinberg.net/forums/viewtopic.php?f=209&t=60985

doesnt work, when im trying to update Cubase LE Ai elements 7.0.7 i says, “there are no operations to perform” and i cant update…

Im using orginial USB cabel i got with the box. Windows 7 and 64bit.


Im going crazy here :imp: :imp: Please help!

Hello,

Because you already have the latest version of Cubase Elements 7 installed.
Are you connecting it to the same USB-port? Is it a USB3 or USB2 port?
On what operating system are you, it will be good if you also posted your system specifications.

Best regards,
GN

Hi.

I have the same problem, followed installation to the letter, same port etc. I have tried the latest driver and rolled back driver. still no joy. Win 7 64bit. It has worked in the past, although some what randomly. The UR22 works on my win 8.1 PC OK

Anthony

UPDATE:

Retried connecting to my Win 8.1 PC. Now I have the same problem with that PC as well!