UR22 inputs disabled in templates

I was working through some of the online tutorials and happened to open a preloaded template from the hub.

I couldn’t hear anything and found that the inputs from my UR22 had been marked as inactive.

Having checked I find that the following hub templates disable/deactivate the inputs from the UR22 when they are loaded:
Acoustic Guitar+Vocal
Clean E-Guitar+Vocal
Distortion Guitar+Vocal
Stereo Acoustic Guitar

. . but when a template is loaded the setting of the UR22 inputs to inactive appears to be ‘sticky’ and loading a project or a template where the inputs were active doesn’t restore them. This has to be done manually in the VST Connections dialogue. There may be other templates affected. This may be a valid topic for the creation of an issues thread. Is anyone else seeing this behaviour, or is it just me?

That’s normal behavior, you need to change the templates

Really? Audio recording templates set up with the audio inputs disabled? Quite daft. The MIDI templates don’t load with MIDI disabled.

However, if that’s the way it’s supposed to be then I can just ignore them.

The i/o VST connection could use an update, but you can save the input and the output configuration separately, at least. The templates where probably made using another sound device, using other names for in and outputs, that’s why they need to be updated to your setup. A few minutes is all it takes, if you want to use templates at all.

I am having a bit of trouble with this issue too. Several templates reset my UR22 inputs as inactive. Problem is that they then will not reset to active via the VST connections tab in the Device Setup. Maybe I need to find another way to activate the inputs. An alternative would be appreciated… I am only
using the templates within Cubase 8.5 pro.