UR22 usb problem, usb light blinking, not connecting


Last time I used my pc (22-2-2015) everything was working fine. Today when i turned on my pc the ur22 usb light was blinking and no connection could be made.
I cannot get it to work any more…
i have windows 8.1 and it worked for the last 6 months or so.
this is what i tried:

  • uninstalled windows updates sinds it last worked(22-2-2015)
  • uninstalled any software sinds 22-2-2015
  • uninstalled al usb drivers
  • updated ur22 drivers(uninstalled drivers. rebooted without ur connected. installed new drivers. rebooted and connected ur)
  • reinstalled the older drivers on the same way.
  • rosolved all warings/ errors in event logs
  • tried it on my laptop
  • tried all available usb ports on laptop and pc
  • tried diffrent cables
  • tried windows 7 and it works…

Does any one have an idea, or do i have to accept that the UR22 broke down after a year without using it intensively?


Its an windows 8.1 update that causes this problem. If any knows wich update it is please let me know!

I have been wrestling with exactly the same problem for a couple of weeks now, but with Windows 10. However, I just tried my UR22 on another PC (Windows 8) and got exactly the same problem, so I am thinking it may be that my UR22 is faulty…

UPDATE - After posting this, I then tried a Windows 7 machine…same problem. Being the OCD kinda guy I am :wink: I had to rule out any dodgy-corrupted-drivers, or hardware-crippling Windows updates being the cause of the issue, so I formatted my hard drive and reinstalled Windows 10…installed the UR22 driver and still no luck, so unfortunately my UR22 is on it’s way back to the shop…bummer!