UR22C MIDI problem (UR-C series in general?)

Greets all,

on iPad Pro 12.9” 2021 and M-Audio Keystation 88 UR22C MIDI input is an absolute disaster. Notes are left sustaining randomly or keypresses are not registered at all. Also, should a keypress register, latency is massive. The problem persists on any app (Cubasis, Auria Pro, Animoog Z, Sampletank, Syntronik, iGrand Piano, Mellowsound etc.) whether the interface is bus-powered or on power adapter.

Windows 10 is fine, whatever the software.

This being the case, the interface is useless to me and I will return it to the vendor at the end of the week unless a solution emerges. I have issued a ticket with Steinberg support.

Anyone with the same problem? Solutions?


I have not tried (yet) using the 5-pin MIDI connections, but I connect my gear (similar setup than yours) to a USB-C hub to my ipad and it works fine. (via USB-MIDI).

Thank you for your answer, Y-D.

However, my point of view is that UR22-C is designed to work with iPad and has a regular 5-pin MIDI i/o, therefore 5-pin MIDI should work with iPad. Frankly, evertything should work as advertised.

Furthermore, although I struggle to explain why, somehow I have always found regular MIDI i/o more reliable than USB-MIDI - until now, that is. I guess I’m just of ye olde worlde. Also, I do have a Yamaha digital piano which only has 5-pin MIDI.

My Focusrite Saffire MIDI works on iPad without hiccups. Not very mobile, though, being rack mount size.


Ok… so I made a test just for you.
The hardest part was finding my old 5-pin midi cables, but everything works flawlessly.
No noticeable latency.
I have both iGrand + Galileo apps layered (both playing), with 2 different keyboards (from Roland and Akai) going 5-pin midi to my ur44c, then to my ipad (no hub).

I’m from ye olde worlde myself… I still have my 1st edition printout of the midi 1.0 spec and my first keyboard was a (brand new) Juno-106… then Korg M1… about 30 years before these became “vintage” ! :wink:

Yves, thank you for going through the hassle, you’re a star, you are!

It is challenging to pinpoint the problem then, as it is not the M-Audio keyboard either since I tested the Yamaha digipiano as well.

You pointed out that you have a similar setup, but I should further enquire, to make sure, if your iPad is iPad Pro with Apple M1 chip same as mine? Therein might lurk a compatibility issue in my case…

I am starting to lean towards a conclusion that my unit itself is faulty.


I have the ur816c and have never been able to get the onboard midi inputs to work reliably. They stutter and choke notes all the time. I’ve resorted to using a usb cable interface for my keyboard instead. I’m hoping this is fixed one day with a driver but I suspect there’s just not enough horsepower in there to run it smoothly. ( onboard FX or no onboard FX)

I don’t have the M1 ipad pro, but the previous version.
My wife has the latest M1 ipad air, so I’ll make a test later, but seriously doubt it’s the issue.

Also, considering all works fine for you in Win10, I doubt also it’s the UR-C unit or cables.
(I assume you made a test by only unplugging the cable from your ipad and plugging it into your Win10 PC, while not touching anything else - please confirm).

So I would suspect a setting in your ipad… (maybe disable “Background App Refresh”?)
Or start removing applications from your ipad that could be fighting for resources in the background without your knowledge.

Quick test: put your ipad in “airplane mode” to rule out some background refresh interference quickly.

Last resort: make a clean reset of the whole ipad and reinstall only iGrand, for example.

Yes, plug out iPad - plug in Win 10 (and 11), repeatedly involving very bad language.

Closing the apps: no help.
Disabling ”Background…”: no help.
Airplane mode: no help.

Clean reset would be quite drastic and would consume ridiculous amount of time and effort.

Steinberg support: When connecting the UR22C to a device such as an iPad, it is necessary to use a USB power adapter or USB mobile battery
The power supply by cable is not enough.

Direct (abbreviated) quote from the product web page: […] iOS ready via CC Mode […] UR22C, UR24C and URd44C can even be bus powered by the USB-C equipped iPad Pro models.

So that is the level of Steinberg support’s knowledge of their own products and selling points.

PS. Oh, and as a delightful little red flag for those who would like to put down their stuff playing midi keybs and singing through them lovely (seriously, I like them a lot) dsp plugins I quote Steinberg support: Do not activate dspMixFx when using a MIDI device. This may interfere with stable data transmission/reception. Cheers, Steinberg.

I confirm it works fine as well with the M1 ipad, and when powered only by the ipad cable alone.

However, I admit I was not using dspMixFx… I’ll test that later.

that seems to imply turning it on while using a MIDI device, but then as soon as its on, it should be fine. I use MIDI on mine and its been fine so far ( w/Reaper)

I confirm that running the dspMixFx app on the ipad does make MIDI unusable.
Actually, the dspMixFx app can still be there in the background, as long as it’s not your main open window.
A bit bizarre, but I don’t see this as a showstopper as you don’t need to be looking at the app for the UR-C to work, unless you want to play with the faders or other settings while playing (I don’t have enough hands myself… :wink: )

Obviously, I do not play keyboards with dspMixFix open in the foreground - who would and why? I have tried everything with and without dspMixFux in the background, foreground, fairground and battleground and, as we discussed, without any other app running at all besides a whatever intrument or Cubasis.

To no avail whatsoever, that is. MIDI is useless.

So the culprit is not the dspMaxFox either.

Try to borrow another ipad to make a test.
You can install the free version of iGrand on a friend’s iPad for a quick test.

The setup you describe works for me (and many others!) and it even works with your Win10 PC… so everything points to your own iPad having something specific about it.
Trying with a different iPad could at least confirm that.

Maybe it’s the ghost of Dave Smith trying to contact me.

1 Like

Hello, I’ve just purchased the Steinberg UR22C sound card and I’m facing a similar issue. I’ve connected my Midistudio-2 keyboard (Miditech) to the “MIDI IN” port on the sound card, all linked to my MacBook Pro M1Pro.

The keyboard is recognized and visible in Cubase, Ableton Live, and other software applications. However, the problem lies in the fact that the notes are being played randomly. Sometimes, different notes are played than the ones I press on the keyboard. Additionally, notes are occasionally sustained even when I’ve released the keys. In essence, this situation is incredibly frustrating and renders the keyboard unplayable.

Have you discovered a solution? It’s worth noting that my keyboard functions flawlessly in my previous setup: iMac Intel paired with the Presonus Firebox sound card. I’ve also tested the UR22C sound card and my keyboard on two Windows PCs, and the symptoms are consistent: notes are played randomly, as if a phantom is engaging in a “four-handed” performance with me (and, to top it off, this phantom doesn’t even know how to play).

Though this is quite late and you may have returned the ur22c. I am facing same issue with Samson Carbon 49 midi controller. It works fine with UCB with IPAD -Cubasis 2. As soon as I connect with 5 pin midi to the UR22c, I am facing identical problems as you are. Unfortunately, I cannot return eigher UR22C or keyboard… Hope someone from Steinberg is able to help.

Firstly, I apologise for being such an self-centered t*rd that I did not update this thread upon finding a ”solution” to the problem.

I returned the unit to the retailer and collected a replacement. I skipped the firmware update and, lo and behold, it worked. No midi-quirks whatsoever.

Until now, that is. I took a (poorly) calculated risk and updated the firmware to 2.01 to see if the problem has been fixed. Well, you know, no. I tried to downgrade back to 1.50, but it failed on Win 11 - I’ll try again on Mac today when I get the chance. Luckily the unit is not bricked due to firmware downgrade failure.

So: do not update the firmware from 1.X! If you have done so, get the old version and, should you find the courage, try and downgrade (which is admittedly risky).

Berated I am for neglecting this thread and all of you with this problem. Truly sorry.

Steinberg: fix it, along with your attitude towards users (and retailers, I’ve found actually)!

Firmware downgrade 2.01 → 1.50 fails on Mac as well, I’m afraid. I’m left with nigh useless unit again, which serves me right in some sense, I suppose.